python-support: pyversions conflicts with ${python:Depends}

Scott Kitterman ubuntu at
Sun Sep 28 02:39:06 UTC 2008

On Thu, 25 Sep 2008 01:26:16 +0400 Ivan Sagalaev 
<maniac at> wrote:
>Writing here since this email is a maintainer for python-support. Feel 
>free to redirect my wherever appropriate and accept my apologies in this 
>I'm building a pure-python package with python-support that is intended 
>to be installed on several platforms with different default python 
>versions (namely Ubuntu Hardy and Debian Sarge). The package requires 
>python 2.4 and above so it includes debian/pyversions with "2.4-".

Sarge shipped a very different Python environment.  Your chances of getting 
a Python package to work on both Sarge and Hardy are just about nil.  Sarge 
is no longer supported by Debian and so it's really past time to move to 
Etch in any case.  With releases with reasonably modern pysupport (all 
supported Debian/Ubuntu releases except Ubuntu Dapper) this is achievable 
with a single source package, but you will likely have to (and should in 
any case) build a binary on the target toolchain for each release you want 
to support. 

>The package is built on Hardy. Trying to install this package on Sarge 
>results in apt-get raising an error about "python (>= 2.4) required but 
>python 2.3.5 is going to be installed". My current theory is that 
>because of building this in an environment with python 2.5 as default 
>version the line "Depends: ${python:Depends}" is replaced with "Depends: 
>python" and doesn't work on a platform where "python" means python 2.3. 
>May be this theory is completely broken, I'm not very familiar with 
>python-support and only partly familiar with deb packaging in general.

The problem here is that your package says it needs Python 2.4 and Sarge 
has only 2.3.  This is expected.  If your package works with 2.3, then 
change pyversions (noting again that Sarge is no longer supported by 

>So I'm looking for an advice on how to resolve this situation. I see now 
>two ways:
>- specify dependencies manually like "python2.4|python2.5"
>- build the package on the lowest (python-wise) platform -- Sarge -- and 
>hope that python-support will do its magic
>Or may be something else...
Give up on Sarge is my advice.  If you can't, don't use pysupport.  Use 
dh_python and do it that way for Sarge/Dapper.

Scott K

More information about the Ubuntu-devel-discuss mailing list