python-support: pyversions conflicts with ${python:Depends}

Ivan Sagalaev maniac at
Wed Sep 24 21:26:16 UTC 2008


Writing here since this email is a maintainer for python-support. Feel 
free to redirect my wherever appropriate and accept my apologies in this 

I'm building a pure-python package with python-support that is intended 
to be installed on several platforms with different default python 
versions (namely Ubuntu Hardy and Debian Sarge). The package requires 
python 2.4 and above so it includes debian/pyversions with "2.4-".

The package is built on Hardy. Trying to install this package on Sarge 
results in apt-get raising an error about "python (>= 2.4) required but 
python 2.3.5 is going to be installed". My current theory is that 
because of building this in an environment with python 2.5 as default 
version the line "Depends: ${python:Depends}" is replaced with "Depends: 
python" and doesn't work on a platform where "python" means python 2.3. 
May be this theory is completely broken, I'm not very familiar with 
python-support and only partly familiar with deb packaging in general.

So I'm looking for an advice on how to resolve this situation. I see now 
two ways:

- specify dependencies manually like "python2.4|python2.5"
- build the package on the lowest (python-wise) platform -- Sarge -- and 
hope that python-support will do its magic

Or may be something else...

Thank you in advance!

More information about the Ubuntu-devel-discuss mailing list