customizing x in intrepid

Matt Price matt.price at
Fri Oct 17 15:05:59 UTC 2008

one of the few regressions i'm experiencing in intrepid is the loss of
certain customizations in X -- most notably changes in the speed of my
synaptics touchpad, which is painfully slow without a bunch of
directives in the relevant InputDevice section.  This wouldn't be so bad
if i could use gsynaptics to configure the device, but shmconfig has
been turned off as well.  

I looked at the skeletal xorg.conf generated by the nex xorg packages,
reproduced here:
Section "Screen"
        Identifier      "Default Screen"
        DefaultDepth    24

Section "Module"
        Load    "glx"
        Disable "dri2"

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
i guess i don't really understand how this works, as htere's no
ServerLayout secion.  I tried adding a new InputDevice section:

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
    Option         "MinSpeed" "0.7"
    Option         "MaxSpeed" "3"
    Option         "AccelFactor" "0.025"
    Option         "SHMConfig" "on"

but this had no effect (and i don't really see why it would, as again,
there's no ServerLayout section.  I also took a look at the synaptics
touchpad page on the wiki: 
and followed the instructions to modify 

this also had no effect.  so i tried adding the same option in to a
couple of the other directives, as i think i actually have an alps
touchpad.  again nothing.  i get the following alps-related messages in
(II) config/hal: Adding input device AlpsPS/2 ALPS GlidePoint
(**) AlpsPS/2 ALPS GlidePoint: always reports core events
(**) AlpsPS/2 ALPS GlidePoint: Device: "/dev/input/event7"
(II) AlpsPS/2 ALPS GlidePoint: Found x and y relative axes
(II) AlpsPS/2 ALPS GlidePoint: Found x and y absolute axes
(II) AlpsPS/2 ALPS GlidePoint: Found absolute touchpad
(II) AlpsPS/2 ALPS GlidePoint: Found 3 mouse buttons
(II) AlpsPS/2 ALPS GlidePoint: Configuring as mouse
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS
GlidePoint" (type: MOUSE)
(**) AlpsPS/2 ALPS GlidePoint: YAxisMapping: buttons 4 and 5
(**) AlpsPS/2 ALPS GlidePoint: EmulateWheelButton: 4,
EmulateWheelInertia: 10, EmulateWheelTimeout: 200

i imagine there's someway to setthese options somewhere, but i still
don't see it...  any hints?  thanks,

Matt Price
matt.price at

More information about the Ubuntu-devel-discuss mailing list