not able to install build-essential package

Onno Benschop onno at
Wed Oct 1 21:34:53 UTC 2008

On 02/10/08 00:45, Gangadhar Moganti wrote:
> Hi,
>    I am new to linux.  I installed ubuntu8.0.4 on my desktop using ubuntu 8.0.4 CD.  I am trying to install ndiswrapper package to access internet using wifi.  While installing I came across some errors and identified that some packages like build-essential are missing.  I tried to install build-essential and came to know that the dependent packages are missing.  I started installing one after another using the packages available on ubuntu CD.  During this I came across a strange situation.  I tried to install g++4.2 package and it said libstdc++6.4.2-dev is missing.  As I noticed that package available on CD, I tried to install it, then it gave me an error saying g++4.2 is missing.  
> I have been struggling to complete this installation for quite some time.   I would appreciate if some one can look into this and help in overcoming the current deadlock.
> Regards,
> Gangadhar

I would first ask which instructions you are following to install
ndiswrapper because compilation and build-essentials does not sound like
you are using the standard Ubuntu tools or methodology, the ndiswrapper
modules should already be with your installation and you will be using a
pre-compiled WiFi driver - that being the point of ndiswrapper in the
first place - but I may be wrong and your WiFi card might need this -
who knows, there seem to be more WiFi chip-sets than there are drops in
the ocean :-)

As for the "chicken and egg" situation you find yourself in, I suspect
the problem would go away if you were to install it with:

apt-get install libstdc++6.4.2-dev g++4.2

Onno Benschop

Connected via Optus B3 at S31°54'06" - E115°50'39" (Yokine, WA)
()/)/)()        ..ASCII for Onno..
|>>?            ..EBCDIC for Onno..
--- -. -. ---   ..Morse for Onno..

ITmaze   -   ABN: 56 178 057 063   -  ph: 04 1219 8888   -   onno at

More information about the Ubuntu-devel-discuss mailing list