Kerberos? Does anyone have this running?

Kevin Fries kfries at
Thu Jan 10 22:02:28 UTC 2008

On Thu, 2008-01-10 at 12:30 -0700, Neal McBurnett wrote:
> My guess is that the server team mailing list, or #ubuntu-server
> or #kerberos would be better places for this discussion.  But read on
> - my comments are interspersed.
> On Thu, Jan 10, 2008 at 06:17:56PM +0100, Magnus Runesson wrote:
> > Do you have the full links to the doc you refer to?
> I second the question :-)   Makes it much easier for the many readers
> of this thread.

The original doc I was trying to follow was:

it fails at step 3.1.3

> > > Is there something going on with Kerberos as to why there is no help, or
> > > bug fixes?  Is this package going the way of the Woolly Mammoth?  Or is
> > > it just not getting enough TLC?  Or, is something else going on?
> I don't know, but my guess is that most of the efforts are going into
> improving interoperability with Active Directory rather than just
> kerberos.  The major news on that front is "Likewise":
>  likewise:

Unfortunately we are a small shop here.  I am already pushing my lab to
the limits without adding AD to the mix, lol.

> I had a problem like that once, and think that it had to do with not
> having a Fully Qualified Domain Name (FQDN) for my system in
> /etc/hosts.  I seem to recall that the kerberos installation uses the
> server's FQDN to make a default realm, and doesn't catch the error if
> that doesn't exist.
> Googling for your error string with the word "launchpad" added (which
> helps google prioritize authoritative launchpad bugs over chat in the
> forums) led me quickly to this:

Yep, saw that, and followed that thread.  But I like many others have
dnsdomainname working correctly, and it is still not working.

> which gives more details on the root problem: dnsdomainname is not
> finding the FQDN.  For me, a gutsy install in which I gave it my FQDN
> at install time properly put my FQDN in the /etc/hosts file, but if
> I just gave it a local name I ran into this kerberos problem.
> This is the format of what worked for me in /etc/hosts:
> example

Tried that and actually configuring DNS.  DNS is now fully up and
running, yet... 

Others in the forums report the same failure despite dnsdomainname
returning correctly.  Yet, there were no responses.  That is why I
decided to ask the developers.  Thinking it may be in the process of
being EOL'd or something.

I may just blow off KRB for this project, since it is not critical,
desirable, but not critical.

Kevin Fries
Senior Linux Engineer
Computer and Communications Technology, Inc
A Division of Japan Communications Inc.

More information about the Ubuntu-devel-discuss mailing list