Need to disable LVM2

Jorge Noa jnoa at
Mon Dec 15 07:18:16 UTC 2008


I mistakenly installed lvm2 package on 8.04 Ubuntu that was using iscsitarget to support lvmoiscsi virtual disks for a remote XenServer. On reboot of machine  LVM seems to detect  the XenServer LVM virtual disks being hosted on the iSCSI Target disk partitions and prevents ietd from successfully accesing these partitions.

I would like to remove LVM from my Ubuntu system but it seems that "apt-get remove/purge lvm2" does not completely remove it because on reboot I still get errors. Any suggestions beyond the ones I have already tried  on how remove or disble LVM (see bellow) ?????

Error Details:
The follwoing are the iscsitarget ietd errors in syslog:

ietd: Can't create a logical unit 16 4 0 Path=/dev/sdb5,Type=blockio

kernel: [  129.727373] iscsi_trgt: blockio_open_path(166) Can't open device /dev/sdb5, error -16

kernel: [  129.727386] iscsi_trgt: blockio_attach(340) Error attaching Lun 0 to Target

Things I have already tried:
1) Using lvremove, vgremove, and pvremove I removed the LVM mappings associated with /dev/sdb5. After I do this, /dev/sdb5 is correctly accessed by ietd restart.

2) Edited /etc/lvm/lvm.conf  to change the filter specification  so that  LVM does not proces /dev/sdb5 or the cdrom (filter = [ "r|/dev/sdb|", "r|/dev/cd|" ]. When I rebooted, pvscan/pvdisplay no longer showed /dev/sdb5 however ietd still got the same errors. After removing filter, /dev/sdb5 again shows up in pvdisplay (without running pvscan). After running step #1 again,  /dev/sdb5 is again correctly accessed by ietd restart.

3) Ran step #1 then did "apt-get remove lvm2" and rebooted, ietd still gets the same errors. I even tried "apt-get purge lvm2" in desperation, no luck.

Any help will be appreciated.

Thanks in advance,


More information about the Ubuntu-devel-discuss mailing list