PulseAudio integration issues

Mackenzie Morgan macoafi at gmail.com
Wed Aug 20 20:00:59 BST 2008


On Wed, Aug 20, 2008 at 2:32 PM, Conn <subpsyke at eircom.net> wrote:
> On Wed, Aug 20, 2008 at 7:21 PM, Mackenzie Morgan <macoafi at gmail.com> wrote:
>> Daniel T Chen says (after I poked him and forwarded him the original
>> email, since he's extremely behind on list mails):
>> Feel free to forward my thoughts to u-d-d.
>>
>> I've been away from development for a bit, so I'll chime in here.
>>
>> WRT 198453, the only piece holding back Kubuntu and Xubuntu is a
>> missing merge for the pulse pcm+ctl alsa-plugins source that falls
>> back to ALSA if an environment variable internal to PulseAudio isn't
>> set.  I'll take some time to put this in an alsa-plugins bzr branch
>> for testing.  Several people in #ubuntu-mozillateam/Freenode have
>> noticed issues in my bzr branch of alsa-lib.  The aforementioned issue
>> goes away with said merge.
>
> That's good to hear. I'm not against this change at all, however, will
> this fallback create any additional overhead for systems where
> PulseAudio isn't installed?

Dan says:  The overhead is the cost of the lookup (existence, setting)
of an environment variable.  In all but the most absurd
configurations, said cost is, for all intents and purposes, a
non-issue.

>> WRT 257043, the workaround may be acceptable in the interim, but
>> coordination is necessary in #ubuntu-mozillateam to ensure that it's
>> not in place unless absolutely necessary.  The packaging itself would
>> need to be fixed:  one cannot assume that /etc/adobe can be blown away
>> blindly in prerm, and the addition to what should be a conffile should
>> not occur in postinst.
>
> I agree absolutely; it was a quick hack in my package as a kind of
> "proof of concept" that the configuration file prevents crashes. Just
> don't forget that your debdiff attached on the bug doesn't include the
> new dependencies for i386 users (I can post an update without the hack
> applied).

Dan says:  Yes, the additional dependencies are necessary for the
flashplugin-nonfree source package.  What has not been determined is
how they will spill over into ia32-libs source (I mentioned briefly in
the previous e-mail).


-- 
Mackenzie Morgan
Linux User #432169
ACM Member #3445683
http://ubuntulinuxtipstricks.blogspot.com <-my blog of Ubuntu stuff
apt-get moo



More information about the Ubuntu-devel-discuss mailing list