Call for testing - unity-control-center (fork of gnome-control-center so we can stay on an old version)

Martin Pitt martin.pitt at
Wed Dec 11 08:12:50 UTC 2013

Hey Robert,

Robert Ancell [2013-12-11 17:42 +1300]:
> Ubuntu makes use of a heavily patched gnome-control-center (61 patches) and
> we will in future move to the new Ubuntu System Settings [1] once we
> achieve convergence. We are already running an old version of
> gnome-control-center (3.6) and the value for Ubuntu in upgrading this is
> low since it would take a lot of work to update our changes. Running an old
> version until convergence blocks those who do use GNOME (i.e. Ubuntu GNOME).

Nice! So it happens at last.

> Please test this PPA and post any problems in the bug report. I'd like to
> land this change into the archive if there are no reasons to block it.

The upgrade went fine, and it replaced most of the
gnome-control-center* packages with the unity-* counterparts, except
for gnome-control-center-data:

$ dpkg -l *control-center*|grep ^ii
ii  activity-log-manager-control-center                   0.9.7-0ubuntu4+unity                               all          blacklist configuration for Zeitgeist (transitional package)
ii  gnome-control-center-data                             1:3.8.6-0ubuntu1+unity                             all          configuration applets for GNOME - data files
ii  libgnome-control-center1                              1:3.6.3-0ubuntu49                                  amd64        utilities to configure the GNOME desktop
ii  libunity-control-center1                              1.0                                                amd64        utilities to configure the GNOME desktop
ii  unity-control-center                                  1.0                                                amd64        utilities to configure the GNOME desktop
ii  unity-control-center-data                             1.0                                                all          configuration applets for GNOME - data files
ii  unity-control-center-signon                           0.1.7~+14.04.20131126.2-0ubuntu1+unity             amd64        Unity Control Center extension for single signon

It seems to me that if we want to add a "real" gnome-control-center,
-data should be migrated as well? Or does u-c-c not need this at all?
(Then it should be cleaned up on upgrade, or get owned by the "real"

After upgrading, the menu entry from the session indicator doesn't
work. This needs a "pkill -f indicator-session-service" or a reboot;
could the pkill perhaps be put into the postinst?

The new control-center window is too wide, but this is probably
related to the transition to GTK 3.10, not due to u-c-c itself.

Many entries are now untranslated, I guess this also changed the
translation domain? Can we copy the translations from g-c-c, so that
they get imported into LP?


Martin Pitt                        |
Ubuntu Developer (  | Debian Developer  (
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <>

More information about the ubuntu-desktop mailing list