[U-co] Problemas Video Intel 945g

jean paul posada mora jeanpaul756 en gmail.com
Jue Abr 30 17:40:36 BST 2009


Hola Jorge y listeros:

Mi board es una d945gcpe y tengo bien configurado el video, este es mi
archivo /etc/X11/xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool,
using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades
*only*
# if it has not been modified since the last upgrade of the
xserver-xorg

# package.
#
# If you have edited this file but would like it to be automatically
updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "es"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "Device"
        Identifier      "Intel Corporation 82945G/GZ Integrated Graphics
Controller"
        Driver          "intel"
        BusID           "PCI:0:2:0"
        VideoRam        512
        Option "XAANoOffscreenPixmaps" "true"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Intel Corporation 82945G/GZ Integrated Graphics
Controller"
        Monitor         "Monitor genérico"
        DefaultDepth    24
        SubSection "Display"
        Modes           "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

##Agregado para Compiz

Section "Extensions"
        Option "Composite" "enable"
EndSection

Section "Module"
        Load  "extmod"
        Load  "glx"
        Load  "dri"
        Load  "dbe"
        Load  "xtrap"
        Load  "GLcore"
        Load  "record"
EndSection

Si  despues de cambiar las cosas que veas que no concuerdan con tu maquina
continuas con problemas, te recomiendo hagas lo siguiente en una consola:

$sudo dpkg-reconfigure xserver-xorg

Suerte

2009/4/29 Jorge Calderon <thelordj en gmail.com>

> Buenas tarde, tengo el problema q no me sirver los driver de video de la
> 945g para 9.04, e intentado modificar el xorg, pero nada, aca les dejo lo
> qtengo, para ver si alguien me peude hechar una mano.
>
> # xorg.conf (X.Org X Window System server configuration file)
> #
> # This file was generated by dexconf, the Debian X Configuration tool,
> using
> # values from the debconf database.
> #
> # Edit this file with caution, and see the xorg.conf manual page.
> # (Type "man xorg.conf" at the shell prompt.)
> #
> # This file is automatically updated on xserver-xorg package upgrades
> *only*
> # if it has not been modified since the last upgrade of the xserver-xorg
> # package.
> #
> # Note that some configuration settings that could be done previously
> # in this file, now are automatically configured by the server and settings
> # here are ignored.
> #
> # If you have edited this file but would like it to be automatically
> updated
> # again, run the following command:
> #   sudo dpkg-reconfigure -phigh xserver-xorg
>
> Section "Device"
>    ### Available Driver options are:-
>        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
>        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
>        ### [arg]: arg optional
>        #Option     "NoAccel"                   # [<bool>]
>        #Option     "SWcursor"                  # [<bool>]
>        #Option     "ColorKey"                  # <i>
>        #Option     "CacheLines"                # <i>
>        #Option     "Dac6Bit"                   # [<bool>]
>        #Option     "DRI"                       # [<bool>]
>        #Option     "NoDDC"                     # [<bool>]
>        #Option     "ShowCache"                 # [<bool>]
>        #Option     "XvMCSurfaces"              # <i>
>        #Option     "PageFlip"                  # [<bool>]
>        Identifier  "Card0"
>        Driver      "i810"
>        VendorName  "Intel Corporation"
>        BoardName   "945G Integrated Graphics Controller"
>        BusID       "PCI:0:2:0"
>
> EndSection
>
> Section "Monitor"
>    Identifier    "Configured Monitor"
> EndSection
>
> Section "Screen"
>    Identifier    "Default Screen"
>    Monitor        "Configured Monitor"
>    Device        "Configured Video Device"
> EndSection
>
>
>
> *y aca el xorg.0.log*
>
> intente con eld river de 8.10 pero tampoco
>
> X.Org X Server 1.6.0
> Release Date: 2009-2-25
> X Protocol Version 11, Revision 0
> Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
> Current Operating System: Linux server-inv 2.6.28-11-generic #42-Ubuntu SMP
> Fri Apr 17 01:57:59 UTC 2009 i686
> Build Date: 09 April 2009  02:10:02AM
> xorg-server 2:1.6.0-0ubuntu14 (buildd en rothera.buildd)
>    Before reporting problems, check http://wiki.x.org
>    to make sure that you have the latest version.
> Markers: (--) probed, (**) from config file, (==) default setting,
>    (++) from command line, (!!) notice, (II) informational,
>    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 29 15:05:51 2009
> (==) Using config file: "/etc/X11/xorg.conf"
> (==) No Layout section.  Using the first Screen section.
> (**) |-->Screen "Default Screen" (0)
> (**) |   |-->Monitor "Configured Monitor"
> (==) No device specified for screen "Default Screen".
>    Using the first device section listed.
> (**) |   |-->Device "Card0"
> (==) Automatically adding devices
> (==) Automatically enabling devices
> (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
>    Entry deleted from font path.
> (==) FontPath set to:
>    /usr/share/fonts/X11/misc,
>    /usr/share/fonts/X11/100dpi/:unscaled,
>    /usr/share/fonts/X11/75dpi/:unscaled,
>    /usr/share/fonts/X11/Type1,
>    /usr/share/fonts/X11/100dpi,
>    /usr/share/fonts/X11/75dpi,
>    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
>    built-ins
> (==) ModulePath set to "/usr/lib/xorg/modules"
> (II) Cannot locate a core pointer device.
> (II) Cannot locate a core keyboard device.
> (II) The server relies on HAL to provide the list of input devices.
>    If no devices become available, reconfigure HAL or disable
> AllowEmptyInput.
> (II) Loader magic: 0x3bc0
> (II) Module ABI versions:
>    X.Org ANSI C Emulation: 0.4
>    X.Org Video Driver: 5.0
>    X.Org XInput driver : 4.0
>    X.Org Server Extension : 2.0
> (II) Loader running on linux
> (++) using VT number 7
>
> (--) PCI:*(0 en 0:2:0) Intel Corporation 82945G/GZ Integrated Graphics
> Controller rev 2, Mem @ 0x50100000/524288, 0x40000000/268435456,
> 0x50180000/262144, I/O @ 0x000020e0/8
> (II) Open ACPI successful (/var/run/acpid.socket)
> (II) System resource ranges:
>    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[B]
>    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
>    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
>    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
>    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
>    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[B]
> (II) LoadModule: "extmod"
> (II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
> (II) Module extmod: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 1.0.0
>    Module class: X.Org Server Extension
>    ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension MIT-SCREEN-SAVER
> (II) Loading extension XFree86-VidModeExtension
> (II) Loading extension XFree86-DGA
> (II) Loading extension DPMS
> (II) Loading extension XVideo
> (II) Loading extension XVideo-MotionCompensation
> (II) Loading extension X-Resource
> (II) LoadModule: "dbe"
> (II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
> (II) Module dbe: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 1.0.0
>    Module class: X.Org Server Extension
>    ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension DOUBLE-BUFFER
> (II) LoadModule: "glx"
> (II) Loading /usr/lib/xorg/modules/extensions//libglx.so
> (II) Module glx: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 1.0.0
>    ABI class: X.Org Server Extension, version 2.0
> (==) AIGLX enabled
> (II) Loading extension GLX
> (II) LoadModule: "record"
> (II) Loading /usr/lib/xorg/modules/extensions//librecord.so
> (II) Module record: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 1.13.0
>    Module class: X.Org Server Extension
>    ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension RECORD
> (II) LoadModule: "dri"
> (II) Loading /usr/lib/xorg/modules/extensions//libdri.so
> (II) Module dri: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 1.0.0
>    ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension XFree86-DRI
> (II) LoadModule: "dri2"
> (II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
> (II) Module dri2: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 1.0.0
>    ABI class: X.Org Server Extension, version 2.0
> (II) Loading extension DRI2
> (II) LoadModule: "i810"
> (II) Loading /usr/lib/xorg/modules/drivers//i810_drv.so
> (II) Module i810: vendor="X.Org Foundation"
>    compiled for 1.6.0, module version = 2.6.3
>    Module class: X.Org Video Driver
>    ABI class: X.Org Video Driver, version 5.0
> (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
>    i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
>    E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, G35, 965Q, 946GZ,
>    965GM, 965GME/GLE, G33, Q35, Q33,
>    Mobile Intel(R) GM45 Express Chipset,
>    Intel Integrated Graphics Device, G45/G43, Q45/Q43, G41
> (II) Primary Device is: PCI 00 en 00:02:0
> (EE) No devices detected.
>
> Fatal server error:
> no screens found
>
> Please consult the The X.Org Foundation support
>     at http://wiki.x.org
>  for help.
> Please also check the log file at "/var/log/Xorg.0.log" for additional
> information.
>
>  ddxSigGiveUp: Closing log
>
>
>
>
> --
> <<rundll32 netplwiz.dll,UsersRunDll>>
>
> Ser vago es algo q llevamos por dentro
>
> ░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
>
> Jorge Calderon
> Webmaster Ubuntu Colombia
> Administrator Joomla
>
> --
> Al escribir recuerde observar la etiqueta (normas) de esta lista:
> http://ur1.ca/0uf7
> Para cambiar su inscripción, vaya a "Cambio de opciones" en
> http://ur1.ca/0uf9
>


Más información sobre la lista de distribución Ubuntu-co