[Bug 898062] [NEW] Please sync pygame 1.9.1release+dfsg-2 (universe) from Debian unstable (main)

Launchpad Bug Tracker 898062 at bugs.launchpad.net
Wed Nov 30 12:32:48 UTC 2011

You have been subscribed to a public bug by Felix Geyer (debfx):

Please sync pygame 1.9.1release+dfsg-2 (universe) from Debian unstable

Explanation of the Ubuntu delta and why it can be dropped:

Patches in the Ubuntu diff have been incorporated into the Debian
package. (The package has also been modernized in various ways, i.e.
source format 3.0 (quilt), dh7-style debian/rules, DEP-5 style
debian/copyright, lintian warnings fixed, etc.)

Changelog entries since current precise version 1.9.1release-0ubuntu4:

pygame (1.9.1release+dfsg-2) unstable; urgency=low

  * Upload to unstable.
  * Repack tarball to remove lib/freesansbold.ttf.
  * Import debian/patches/set_the_SDL_WM_CLASS_when_running_under_X11.diff
    from Ubuntu.
  * Drop debian/patches/documentation_fix since the revised link doesn't seem
    to work either.
  * Update debian/copyright to conform to DEP-5.
  * Update debian/rules to dh 7 rules.tiny style.
  * Modify debian/watch to ensure uscan can process it correctly.
  * Add Vcs-* fields in debian/control.
  * Add Homepage: field in debian/control.

 -- Vincent Cheng <Vincentc1208 at gmail.com>  Sun, 25 Sep 2011 17:41:16

pygame (1.9.1release-1) experimental; urgency=low

  * Upload to experimental.
  * New upstream release. (Closes: #544347)
  * Add myself to uploaders.
  * Add build dependency on libportmidi-dev.
  * Transition to dh_python2: (Closes: #616965)
    - Remove dependency on python-central.
    - Bump dependency on python-all-dev to >= 2.6.6-3~.
    - Remove XB-Python-Version.
    - Change XS-Python-Version to X-Python-Version.
    - Use dh_python2 instead of dh_pycentral in debian/rules.
  * Add timidity as a suggested package for python-pygame. (Closes: #428070)
  * Include a doc-base registration file. (Closes: #451674)
  * Update Standards version from 3.8.4 to 3.9.2, no updates required.
  * Update debhelper compatiblity level from 7 to 8.
  * Import debian/patches from Ubuntu.

 -- Vincent Cheng <Vincentc1208 at gmail.com>  Wed, 29 Jun 2011 14:56:36

pygame (1.8.1release-2) unstable; urgency=low

  * Switch to dpkg-source 3.0 (quilt) format
  * Add debian/python-pygame.bug-presubj . The contents of this file are
    displayed to the user by the bug reporting tool before allowing the
    user to write a bug report. This file explains that the user may need
    to install some libsdl libraries to hear audio.
  * bump standard, no changes
  * fix lintian warnings:
    - duplicate-font-file usr/share/pyshared/pygame/freesansbold.ttf
       also in ttf-freefont : replace with symlink
    - some executable-not-elf-or-script
    - debhelper-but-no-misc-depends, added
  * Thanks morph for NMU.

 -- A Mennucc1 <mennucc1 at debian.org>  Sun, 07 Mar 2010 14:58:47 +0100

** Affects: pygame (Ubuntu)
     Importance: Wishlist
         Status: Triaged

** Tags: sync
Please sync pygame 1.9.1release+dfsg-2 (universe) from Debian unstable (main)
You received this bug notification because you are a member of Ubuntu Package Archive Administrators, which is subscribed to the bug report.

More information about the ubuntu-archive mailing list