In precise what happened with usb-creator-gtk application?

Luke Yelavich themuso at
Wed Feb 22 21:30:10 UTC 2012

On Wed, Feb 22, 2012 at 05:05:40PM EST, Hammer Attila wrote:
> Hy,
> In precise if I run usb-creator-gtk or gksu usb-creator-gtk command,
> the USB Startup Disk Creator application UI interface is
> inaccessible with Orca.
> What happened this application? This application not using a
> standard Gtk3 UI interface?

So far as I understand it, it has to do with threading. USB creator used to be accessible, however when you tried to copy an Ubuntu image to a USB drive, USB creator would freeze if orca was running. THis is a bug in GTK do to with threading and accessibility. To work around it, the GTK UI was moved to another thread, however this has made USB creator inaccessible.

What I *think* is going on, is that the atk bridge module is being loaded in the main thread, even though the GTK ui is in another thread, so, the atk bridge module cannot find any GTK UI to interface with. I suspect the solution is loading the atk bridge module in the same thread as GTK, but I haven't worked out how this could be done yet.


More information about the Ubuntu-accessibility mailing list