Ted Gould ted at
Thu Oct 8 21:03:25 UTC 2015

On Thu, 2015-10-08 at 12:48 -0700, Vani Desai wrote:
> Thanks Ted. Your suggestions worked. I see cherrypy webserver running
> at launch. I can access cherrypy hello world webpage on my host PC
> browser. 


> 1. I see this message "Signature check failed, but installing anyway
> as requested" when I install a snap on Snappy QEMU. How do I get valid
> signature for my snap?

The signature comes from the store, if you want you can upload your snap
to the store and then any device running snappy can install it with a
"snappy install" command. There is a lot more information on the store

> 2. I installed snappy example py3-project on Snappy QEMU. It has
> I can't run that python program on Snappy. How to execute
> program installed with Snap manually?

If you look at the snapcraft file for that example:

You can see the name of the package is "spongeshaker" and the name of
the binary is "sha3sum". So there will be a binary in the path called:
spongeshaker.sha3sum You can execute it using that. If you'd like to see
the script that is generated that is in /apps/bin/

> 3. I have webdm installed on Snappy QEMU.I am not able to access webdm
> from my host PC browser. I tried webdm.local:8080 or localhost:8080

What command did you use to start QEMU? The command on the webpage maps
that port into the local QEMU session's 4200. But if you don't do a
mapping QEMU won't pull out the ports into localhost. I'm not sure, but
I don't believe the mDNS support will work in QEMU (the .local address)
without a more complex network config.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the snappy-app-devel mailing list