Component clarification

Daniel van Vugt daniel.van.vugt at
Mon Oct 28 02:41:29 UTC 2013

Yeah, very good point about "gbm". That confused me when I joined to 
project too. It should be called "dri", I think.

And yes, there are some components that are clearly not graphical -- 
input, protobuf. However that leaves "compositor" and "surfaces" in the 
least, which we're saying are not part of "graphics". That's confusing.

- Daniel

On 25/10/13 22:22, Kevin Gunn wrote:
> Don't take me wrong, i'm all for making things less confusing.
> But to the statement the "whole project is about graphics" isn't
> completely true imho, there's also input. To me anything that's related
> to reading, writing, manipulating pixel data is worthy of being referred
> to as graphics.
> I'm ok with "state & implementation code" changing from "surface" to
> "core". I'm sure others will weigh in.
> to be clear, a "surface" is any buffer/container of pixel data that a
> app/compositor wants rendered (potentially placed on screen)
> also, just challenging (as i really don't know the answer)...but is
> mir::gbm heading down a "confusing" path?? is it _really_ gbm specific ?
> or is it also specific to other things (drm, kms etc)...?
> also...alot of people don't know what "gbm" is outside of graphics stack
> junkies (i had to explain what it was to a very savvy person just
> yesterday...that when mir team says "gbm" they really mean desktop)
> also consider suggested "android"....not "gralloc" for
> thot
> br,kg
> On Fri, Oct 25, 2013 at 2:37 AM, Daniel van Vugt
> <daniel.van.vugt at <mailto:daniel.van.vugt at>>
> wrote:
>     OK, let's try again. There seems to be reasonable agreement that at
>     least some components are poorly named and therefore confusing. Of
>     course, any change requires significant search and replace in the
>     least so I'd like to discuss it before any proposals occur.
>     How about...
>     mir::surfaces:: --> mir::core::
>     This component already represents the core platform-independent
>     state and implementation code. So rather than call it "surfaces"
>     which confuses the numerous existing Surface classes (75% of which
>     are not in the "surfaces" component), why not call the component
>     "core" or some such?
>     mir::graphics::*:: --> mir::platform::*:: or
>     mir::graphics::*:: --> mir::*::
>     The whole project is about graphics so we need to stop calling one
>     component "graphics". This component already represents the
>     platform-specific code. So why not name it "platform" or even remove
>     the word "platform"/"graphics" completely and use the actual
>     platform name mir::gbm::, mir::android:: etc?
>     - Daniel
>     --
>     Mir-devel mailing list
>     Mir-devel at <mailto:Mir-devel at>
>     Modify settings or unsubscribe at:
>     <>

More information about the Mir-devel mailing list