Daniel van Vugt
daniel.van.vugt at canonical.com
Fri Oct 25 07:37:17 UTC 2013
OK, let's try again. There seems to be reasonable agreement that at
least some components are poorly named and therefore confusing. Of
course, any change requires significant search and replace in the least
so I'd like to discuss it before any proposals occur.
mir::surfaces:: --> mir::core::
This component already represents the core platform-independent state
and implementation code. So rather than call it "surfaces" which
confuses the numerous existing Surface classes (75% of which are not in
the "surfaces" component), why not call the component "core" or some such?
mir::graphics::*:: --> mir::platform::*:: or
mir::graphics::*:: --> mir::*::
The whole project is about graphics so we need to stop calling one
component "graphics". This component already represents the
platform-specific code. So why not name it "platform" or even remove the
word "platform"/"graphics" completely and use the actual platform name
mir::gbm::, mir::android:: etc?
More information about the Mir-devel