[lubuntu-users] Activating a swap partition

Aere Greenway Aere at Dvorak-Keyboards.com
Sat Nov 24 19:28:54 UTC 2018

On 11/24/18 11:49 AM, Ian Bruntlett wrote:
> Hi,
> On behalf of the Computer Wombling Project I am refurbishing a donated 
> Toshiba NB250-107 netbook. It has a 64-bit CPU and 1GiB RAM. Because 
> of that I installed 32-bit Lubuntu 18.04.1. Whenever I try to open a 
> (small) document with LibreOffice Writer, the hard drive whirs a bit, 
> some of the LibreOffice window appears... and then LibreOffice closes.
> I think it is running out of memory. I've put a 2GiB partition on the 
> hard drive but that does not seem to be used. Here is the output of 
> the swapon --summary command:-
> Filename                Type        Size    Used Priority
> /dev/sda1                                  partition 1998844    0    -2
> Thanks :)
> Ian
> -- 
> -- ACCU - Professionalism in programming - http://www.accu.org
> -- My writing - https://sites.google.com/site/ianbruntlett/
> -- Free Software page - 
> https://sites.google.com/site/ianbruntlett/home/free-software
That problem sounds like what I encountered.  When I submitted the 
bug-report, here is the reply I got, which turned out to be the solution 

That's very likely a duplicate of bug #1699772.

To confirm this, can you run the following command in a terminal:

     sed -i '/enabled/c\<enabled xsi:nil="false">false<\/enabled>'

Then execute libreoffice writer and let me know if the crash is still
happening? Thanks!

[For the record, that command disables the JRE (Java Runtime Environment) in libreoffice, which is known to cause crashes on 32bits processors. Some functions of libreoffice won't work without Java (the most visible probably being libreoffice base), but most of the office suite should work just fine.]

** Changed in: libreoffice (Ubuntu)
        Status: New => Incomplete

-- You received this bug notification because you are subscribed to the 
bug report. https://bugs.launchpad.net/bugs/1804134 Title: LibreOffice 
Writer Won't Run on Pentium-4 32-bit Computer Status in libreoffice 
package in Ubuntu: Incomplete Bug description: On a Dell GX-270 (Intel 
32-bit) computer running Lubuntu 18.04, I can run LibreOffice, but when 
I select LibreOffice Writer the LibreOffice window disappears, and 
nothing happens, as if the application just terminated normally, without 
doing anything. An AppPort window reporting an error appeared, but when 
I clicked its "Send" button, the window disappeared without doing 
anything. If I run LibreOffice Writer directly from the menu, I get a 
frame of its window (with nothing filled-in inside), which persists for 
awhile, and then disappears. In either case, no error message appears, 
and nothing further happens. LibreOffice Calc, on the other hand, 
appears to run, though I haven't tried any spreadsheet using it. I 
expected LibreOffice Writer to initialize, and then use it for editing 
documents (as it did on Lubuntu 16.04), but the LibreOffice Writer 
window disappeared. The same problem occurred on a Dell GX-260 computer. 
ProblemType: Bug DistroRelease: Ubuntu 18.04 Package: libreoffice-writer 
1:6.0.6-0ubuntu0.18.04.1 ProcVersionSignature: Ubuntu 
4.15.0-36.39-generic 4.15.18 Uname: Linux 4.15.0-36-generic i686 
ApportVersion: 2.20.9-0ubuntu7.4 Architecture: i386 CurrentDesktop: LXDE 
Date: Mon Nov 19 21:48:52 2018 InstallationDate: Installed on 2018-06-24 
(148 days ago) InstallationMedia: Lubuntu 18.04 LTS "Bionic Beaver" - 
Release i386 (20180426) SourcePackage: libreoffice UpgradeStatus: No 
upgrade log present (probably fresh install) To manage notifications 
about this bug go to: 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20181124/1a85d091/attachment.html>

More information about the Lubuntu-users mailing list