[lubuntu-users] Bionic 18.04 . . . file "locked" after zsync-ing???

Israel israeldahl at gmail.com
Sat Feb 17 16:23:17 UTC 2018

On 02/17/2018 10:06 AM, Fritz Hudnut wrote:
> Lu users:
> Yesterday, after many months brooding over the loss of PPC I decided
> to try to get back into the Lubuntu game and I tried to download the
> "daily" from the "cdimage" site for Lubuntu 18.04 . . . and that
> process alone brought several issues for the "live-amd64" iso version.
> First issue was that the iso showed "986 MB" . . . which on my slow
> dsl line should ideally have taken about an hour to download . . .
> after several hours of "downloading" had passed I noticed that FF had
> a little dot over its download manager--"download failed" it said.  I
> "retried" several times . . . all attempts on reloading what was then
> "586 MB" failed.  I again started a fresh download . . . and several
> hours later it "finished" at the proscribed "986MB" . . . .  Awhile
> later I checked the shasum 256 number and they didn't match, and I
> tried the md5 number and that didn't match either.
> Took a break and went for a bike ride, came up with the idea of trying
> to reload the file using "zsync" which I noticed was an option.  I had
> to install zsync in my latest squeeze Gecko MATE rolling edition, and
> I downloaded the zsync file and ran "sudo zsync
> http://cdimage.ubuntu.com/daily-live/current/bionic-desktop-amd64.iso.zsync"
> . . . and zsync did its thing, read the seed file and . . . another
> several hours later we had what is now a "1.5 GB" file . . . popped
> the DVD into the drive and ran Brasero . . . disk ejected "failed to
> read file" . . . tried another disk, same result. 
> Looking at the new zsync-d file there is now a "lock" icon, and
> looking in properties via right click it shows "root" ownership with
> "read-only" and somewhere at the bottom of the window it said, "You
> don't have proper permissions so you can't do anything with this file
> . . . " ???  Something like that, so somehow the "old" file which had
> no "lock" icon on it, went to something that has been "locked" by
> zsync?? 
> Any way to get that file unlocked, so that I can get the roughly 6
> hours of computer time spent "downloading" the file back from the
> trash bin of time and get to the "testing" part of the ritual?
> F
Hi Fritz,

You ran 'sudo' before the zsync command.

You now need to run sudo chown $USER:$USER /<name of iso>/

Where /<name of iso>/ is the actual filename (and path if you are not in
the directory which has the file).

It is locked because root owns it (since you ran sudo).

It should be fine, but don't run zsync as super user in the future :D


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20180217/39463621/attachment.html>

More information about the Lubuntu-users mailing list