Lubuntu 14.04.2 alternate.iso: No installable kernel was found in the defined APT sources

Nio Wiklund nio.wiklund at
Thu Feb 19 19:05:12 UTC 2015

[SOLVED, see the end of this mail]

Den 2015-02-17 21:34, Nio Wiklund skrev:
> Den 2015-02-17 12:07, Nio Wiklund skrev:
>> Hi everybody,
>> [Sorry, I missed the link in the previous mail]
>> I iso-tested the current Vivid mini.iso (32-bit) and found a bug.
>> No installable kernel was found in the defined APT sources
>> _____
>> The minimal installer was booted with forcepae. It started nicely, but
>> got stuck when preparing to download and install the kernel.
>> No installable kernel was found in the defined APT sources ... Continue
>> the installation without installing a kernel?
>> I checked if this is a PAE issue ... and yes, it is.
>> Forcepae makes the installer work, but later on, during installation, it
>> refuses to manage the [PAE] kernel. I tested, and it works in a computer
>> with CPU with a built-in PAE flag. And the trusty mini.iso can install
>> in the same computer, so this is a regression.
>> I mark it as a critical bug, because it is critical for computers with
>> Pentium M and Celeron M computers, that have PAE capability but lack PAE
>> flag. But yes, I know, that it does not affect computers with processors
>> that display a PAE flag. I have even tested that is works for such a
>> computer.
>> If you have a computer with a Pentium M or Celeron M CPU, please click
>> on 'Affects me too'!
>> Best regards
>> Nio
> This same problem occurs during iso-testing for the point version
> 14.04.2 LTS
> lubuntu-trusty-alternate-i386.iso
> This alternate iso file does not work in my computer with a Pentium M
> processor.
> Best regards
> Nio

Hi everybody,

Chris Bainbridge solved this problem for us:

The problem is not PAE, the problem is that the kernel parameters parser
was changed as a result of the systemd debug params controversy.

You need to repeat the 'forcepae' twice in the linux kernel parameters,
before and after the -- i.e.:

        linux ... forcepae -- forcepae

Kernel patch that changed the previous behaviour was:

        commit 51e158c
        Author: Rusty Russell <rusty at>
        Date: Mon Apr 28 11:34:33 2014 +0930
            param: hand arguments after -- straight to init

        The kernel parses parameters from the kernel command line up to
        if it doesn't recognize a parameter and it doesn't contain a
'.', the
        parameter gets passed to init: parameters with '=' go into init's
        environment, others are passed as command line arguments to init.
        Everything after "--" is passed as an argument to init.

With "forcepae -- forcepae" I did a full install of the Vivid ISO link
above. It worked ok.

(There was a non-related bug, Ubuntu/grub puts "vt.handoff=7" in
grub.cfg which causes a black screen on boot - looks like bug #913731 or
some related regression).

I can confirm that it works according to this specified usage of double
boot options:

I tested the Ubuntu Vivid daily 32-bit mini.iso (dated feb 9) in my IBM
Thinkpad T42 with Pentium M, and it works for me too with this double
boot option.

I clicked tab to get to the boot line.

I edited the boot line from

> linux vga=788 initrd=initrd.gz -- quiet


> linux vga=788 initrd=initrd.gz forcepae -- quiet forcepae

and the installation of a minimal text system worked for me.


I tested Lubuntu trusty-alternate-i386.iso (14.04.2 LTS) in my IBM
Thinkpad T42 with Pentium M, and this bug is squashed here too with this
double boot option.

I clicked F6 and ESC to get to the boot line and changed the end of it from

... quiet --


... quiet forcepae -- forcepae

But the other red bug (1417918) must be solved by other methods.


It is funny that the corresponding Lubuntu desktop installer works with
the single boot option

... quiet -- forcepae

Best regards

More information about the Lubuntu-users mailing list