Lost my GUI in 14.10

Basil Fernie basil at pop.co.za
Tue Sep 9 16:36:49 UTC 2014

Hi Israel,

Thanks for the as always considerate response.

1. I tried the sudo apt-get update && sudo apt-get upgrade

although I wonder if this has any more effect than issuing the two  
commands separately but consecutively. Anyway it downloaded and installed  
another 1-2MB of files which might just have been very recently released  
to the repositories? Whatever, the whole thing still failed on the  
sane-utils as before.

There's enough Trusty Tahr floating around to thwart the other sudo which  
reports there isn't a new release to upgrade to.

Regarding the /home trick, I'm confused. First, does  /home contain all my  
chosen and explicitly installed apps as well as data in eg Documents and  
Downloads folders? What about system-tied apps, e.g. utilities, which  
might be replaced in the new release by proxies not to my liking? How can  
I retain those without fouling up the new installation? I seem to recall  
that updated versions of LibreOffice get installed in /opt...

Second, how do I redirect OS searches for /home away from the default disk  
to the substitute, POST-installaion of the new release? (I'm presuming  
that if the desirable /home is on sda6 and I am clean-installing to sda7,  
involving formatting of sda7, and I rediract /home to sda6 DURING the  
installation, the installer is going to wipe the /home on sda6, if not the  
whole of sda6, as well as sda7

Any authoritative responses will be very welcome! I like the /home idea as  
it suggests the potential of having a variety of Debian-based distros  
accessing a common data- and- application base... but, "better safe than  


On Mon, 08 Sep 2014 15:34:36 +0200, Israel <israeldahl at gmail.com> wrote:

> Hi Basil,
> I generally do a 'clean' install for each new release.
> I usually keep my /home in a separate partition,
> and simply reinstall using a Live USB.
> You could try simply updating your system from a terminal
> sudo apt-get update && sudo apt-get upgrade
> or perhaps.
> sudo do-release-upgrade
> Of course you may need to move your configuration files to a backup, and
> let the current system re-make them for you.
> If you have an issue, we would like to help if we can :)
> On 09/08/2014 05:11 AM, Basil Fernie wrote:
>> ...or, Lost MY GUI in 14.04!
>> Been watching this one with a sort of morbid interest, because my laptop
>> is sitting with a failed upgrade from 12.04.? Symptoms include  a
>> frequent
>> failure to display desktop on boot apart from taskbar across bottom of
>> screen and conky in top right-hand corner (at least the Xserver is
>> presumably working), I can select and run any application from the main
>> Lubuntu menu, so am not totally immobilised, but try "Send to gesktop"?
>> Nothing visible happens.
>> Also lack of the volume control applet icon on the taskbar so I have no
>> convenient means of muting sound. Certainly the sound is working, but
>> there is no control on the desktop. Task Manager advises pulseaudio at
>> work, also reveals
>> gvfs-afc-volume-monitor  and gvfs-ufd-volume-monitor  and
>> gvfs-gphoto2-volume-monitor  are active, whatever they may be I don't
>> know how to control them or even if I should be able to.
>> And I have 817 uninstalled upgrades waiting for ...what? That number
>> has come down from over 830 after repeated apt-get update, apt-get
>> upgrade, apt-get autoremove sequences; it has stuck now stubbornly on
>> 817. Seems to be blocked by a purported lack af sane-devices (but I
>> can scan without difficulty from my HP DeskJet F4180...)
>> Every now and then a "System Upgrade" advisory window opens - if I
>> click "Run" it frowns at me and says "This program cannot do an
>> upgrade from "Trusty" to "Precise". Which is understandable, but I was
>> rather hoping it wouls complete the upgrade from the older to the newer.
>> Oh, and I have 2  instances of   nmapplet-manager  running after boot,
>> but this is a know and resolved issue.
>> All this in the wake of an attempted click-and-lean-back,
>> watch-the-terminal-messages-scrolling-past automated upgrade from
>> 12.04.04 to 14.04.1 (I had decided to wait for the first point update
>> to be released, memories of Microsoft days, better safe than sorry
>> right?)
>> Earlier, though, while still purportedly runnining on 12.04.?, and
>> religiously using "Update Manager" to stay, well, up-to-date, I wwould
>> be instructed to insert my 14.04 CD (DVD) as some needed files were on
>> it. So I did, the ISO DVD with which I had done live boots for
>> version-testing, and concluded that I would wait for 14.04.1 before
>> doing the system upgrade. Apparently UM couldn't penetrate the .iso
>> barrier (directory structure) to find the files it needed... Which
>> CD/DVD was it looking for, please advise? Surely this shouldn't be a
>> problem?
>> So while I would be delighted to help test L14.10, I'm not too
>> sanguine about committing time to a version which it doesn't seem will
>> be clear of the problems I already face, but will have the added
>> problem, I hear, that  synaptiks won't be usable with it. Synaptiks is
>> the only reason I can type this e-mail on my laptop without going
>> crazy. This could be show-stopper stuff.
>> Currently I'm transferring workload bit-by-bit to a parallel
>> installation of LXDE 14.04.1 which of course depends heavily on
>> Lubuntu. It's not perfect, of course, but seems to be clear of most of
>> the hassles encountered here - so far.
>> Strength and fortitude and great appreciation to all,
>> Basil Fernie
>> On Sun, 07 Sep 2014 10:34:24 +0200, Henk Terhell <hterhell at chello.nl>
>> wrote:
>>> There are still several issues on both Lubuntu 14.10 and Xubuntu
>>> 14.10 on my device.
>>> Main issues are:
>>> Lubuntu 14.10:
>>> - only after a terminal upgrade of nvidia driver 304 I get a GUI
>>> back.The automatic upgrade from the menu of the software updater gave
>>> me again the old version of 304.123 resulting in a blank screen.
>>> - login is required after screen time-out, which cannot be switched
>>> off. The handling through Xfce Power Manager is confusing and doesn't
>>> function well (e.g. system sleep mode cannot be changed from
>>> suspend). Installing xscreensaver could help to control the handling
>>> of screen time-out, but such action is not needed in L14.04.
>>> I will replace shortly my current L14.10 with a fresh daily build and
>>> see what happens, but I don't expect differences.
>>> Xubuntu 14.10:
>>> - only from terminal login and command startx I get a GUI with latest
>>> driver 304.123
>>> - although the nvidia sound card is recognized with command inxi -AG,
>>> there is no output to the internal monitor speakers (in lubuntu 14.10
>>> there is no sound problem at all)
>>> Henk
>>> Israel schreef op 6-9-2014 om 20:25:
>>>> Great Henk!
>>>> So everything works for both L(X)ubuntu?
>>>> This issue shouldn't be present then in the daily builds, is this
>>>> correct?
>>>> You say there is a sound problem now?
>>>> Is this for Lubuntu or Xubuntu?
>>>> Maybe testing the daily image for Lubuntu will confirm that the
>>>> startx/nvidia issue is fixed.
>>>> On 09/06/2014 03:19 AM, Henk Terhell wrote:
>>>>> I just read about an upgrade fix that was issued for nvidia 304.123
>>>>> (see https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1365336  
>>>>> at
>>>>> #45; there is an explanation at #32)
>>>>> Xubuntu 14.10 still needs startx to boot the desktop after an upgrade
>>>>> to this driver was received.
>>>>> Very strange there is still a sound problem in this distro.
>>>>> In Lubuntu 14.10 I did therefore also an upgrade sudo upgrade
>>>>> nvidia-304  and got the desktop back!
>>>>> Henk
>>>>> Israel schreef op 5-9-2014 om 22:33:
>>>>>> Hi Henk,
>>>>>> So, if I understand you
>>>>>> Lubuntu cannot enter the Destkop, because it cannot start the
>>>>>> xserver.
>>>>>> Xubuntu fails to start the Xserver, but can start it from terminal.
>>>>>> Is this correct?  The issue may still be the display manager since
>>>>>> Xubuntu does not start X automatically.  However there is a
>>>>>> possibility
>>>>>> that Xorg in Utopic has changes that make supporting your card
>>>>>> difficult.  I wonder if there are any xorg or xserver updates
>>>>>> since you
>>>>>> downloaded Lubuntu.  I think someone with more understanding of the
>>>>>> entire display process of Linux needs to jump in here...
>>>>>> But...  keep an eye on the updates, and see what packages come in an
>>>>>> either fix or break the machine.  I may set up a VM to test this,
>>>>>> but I
>>>>>> have some other stuff going on right now that is taking up a lot of
>>>>>> time :)
>>>>>> On 09/05/2014 02:46 PM, Henk Terhell wrote:
>>>>>>> Strange enough Xubuntu 14.10 on the same PC doesn't start in GUI  
>>>>>>> but
>>>>>>> hangs after every boot at the terminal. After login and StartX the
>>>>>>> desktop appears.
>>>>>>> Both nouveau and NVDIA 304.123 video drivers do work well in  
>>>>>>> Xubuntu
>>>>>>> 14.10 without any screen freezes so far . So there is difference
>>>>>>> with
>>>>>>> Lubuntu 14.10.
>>>>>>> In Lubuntu 14.10, sound handling is much improved and worked for me
>>>>>>> out-of-the-box.
>>>>>>> In Xubuntu 14.10 I haven't yet figured out how to get sound as
>>>>>>> Pulseaudio cannot find there my built-in monitor speakers.
>>>>>>> Henk
>>>>>>> Henk Terhell schreef op 5-9-2014 om 17:12:
>>>>>>>> Thanks Israel
>>>>>>>> I had filed a bug report #1363919 in the nvidia drivers section
>>>>>>>> some
>>>>>>>> days ago as I couldn't find a related report.
>>>>>>>> The screen dump of startx is different as before. It now only
>>>>>>>> shows a
>>>>>>>> non-fatal error about XKEYBOARD keymap compiler (Type
>>>>>>>> "ONE_Level" has
>>>>>>>> 1 levels but <RALT> has 2 symbols).
>>>>>>>> A good idea to install Xubuntu 14.10 alongside. I'll let you know.
>>>>>>>> Henk
>>>>>>>> Israel schreef op 5-9-2014 om 16:24:
>>>>>>>>> Hi Henk,
>>>>>>>>> My guess is that this is something to do with lightdm still,  
>>>>>>>>> since
>>>>>>>>> you
>>>>>>>>> just got an upgrade for it.
>>>>>>>>> That would be the place to start looking.  You could search
>>>>>>>>> Launchpad to
>>>>>>>>> see if there is a bug related to this issue.  If you cannot
>>>>>>>>> find any,
>>>>>>>>> I'd suggest opening a bug for it.  It may effect users of
>>>>>>>>> different
>>>>>>>>> desktop environments as well, and then we can know that it is
>>>>>>>>> not a
>>>>>>>>> Lubuntu specific issue.  If it is specific to Lubuntu then it
>>>>>>>>> may be
>>>>>>>>> related to the Lubuntu session file.... (sorry I can't remember
>>>>>>>>> what it
>>>>>>>>> is called at the moment).  This is the Lubuntu specific 'startx'
>>>>>>>>> command.
>>>>>>>>> I am guessing you still cannot 'startx' and get X up.
>>>>>>>>> You could also try downgrading lightdm, I suppose, but that can  
>>>>>>>>> be
>>>>>>>>> rather messy when you do things like that...
>>>>>>>>> Another option would be to install something like Xubuntu in a
>>>>>>>>> secondary
>>>>>>>>> partition and see if you are effected with the same issue when  
>>>>>>>>> you
>>>>>>>>> update.
>>>>>>>>> Hope this is fully fixed before release!
>>>>>>>>> On 09/05/2014 08:34 AM, Henk Terhell wrote:
>>>>>>>>>> Hi Israel
>>>>>>>>>> If I recall correctly I got two times upgrades of 14.10 in
>>>>>>>>>> last two
>>>>>>>>>> days, 3 sept. and today.
>>>>>>>>>> Lost my desktop again with the first one.
>>>>>>>>>> The output of your command is below:
>>>>>>>>>> Henk
>>>>>>>>>> libdvdnav4:i386
>>>>>>>>>> simple-scan:i386
>>>>>>>>>> python3-gi:i386
>>>>>>>>>> linux-headers-generic:i386
>>>>>>>>>> linux-image-generic:i386
>>>>>>>>>> linux-libc-dev:i386
>>>>>>>>>> python-gi:i386
>>>>>>>>>> python-gobject:all
>>>>>>>>>> python3-update-manager:all
>>>>>>>>>> update-manager-core:all
>>>>>>>>>> update-manager:all
>>>>>>>>>> libldap-2.4-2:i386
>>>>>>>>>> chromium-codecs-ffmpeg-extra:i386
>>>>>>>>>> lshw:i386
>>>>>>>>>> usb-creator-gtk:i386
>>>>>>>>>> usb-creator-common:i386
>>>>>>>>>> lightdm:i386
>>>>>>>>>> liblightdm-gobject-1-0:i386
>>>>>>>>>> language-pack-en:all
>>>>>>>>>> language-pack-gnome-en:all
>>>>>>>>>> iproute2:i386
>>>>>>>>>> libmpdec2:i386
>>>>>>>>>> libhunspell-1.3-0:i386
>>>>>>>>>> libstartup-notification0:i386
>>>>>>>>>> python3-problem-report:all
>>>>>>>>>> python3-apport:all
>>>>>>>>>> apport:all
>>>>>>>>>> apport-gtk:all
>>>>>>>>>> libfm-extra4:i386
>>>>>>>>>> libfm-gtk-data:all
>>>>>>>>>> libfm-data:all
>>>>>>>>>> libfm-gtk4:i386
>>>>>>>>>> libfm4:i386
>>>>>>>>>> libfm-modules:i386
>>>>>>>>>> upstart:i386
>>>>>>>>>> upstart-bin:i386
>>>>>>>>>> systemd-shim:i386
>>>>>>>>>> binutils:i386
>>>>>>>>>> cpp:i386
>>>>>>>>>> gcc:i386
>>>>>>>>>> g++:i386
>>>>>>>>>> pcmanfm:i386
>>>>>>>>>> lxshortcut:i386
>>>>>>>>>> libitm1:i386
>>>>>>>>>> libgomp1:i386
>>>>>>>>>> gcc-4.9-base:i386
>>>>>>>>>> libstdc++6:i386
>>>>>>>>>> libasan1:i386
>>>>>>>>>> libubsan0:i386
>>>>>>>>>> libcilkrts5:i386
>>>>>>>>>> libatomic1:i386
>>>>>>>>>> libquadmath0:i386
>>>>>>>>>> libgcc-4.9-dev:i386
>>>>>>>>>> cpp-4.9:i386
>>>>>>>>>> gcc-4.9:i386
>>>>>>>>>> g++-4.9:i386
>>>>>>>>>> libstdc++-4.9-dev:i386
>>>>>>>>>> libgcc1:i386
>>>>>>>>>> libpulse0:i386
>>>>>>>>>> libpulse-mainloop-glib0:i386
>>>>>>>>>> linux-libc-dev:i386
>>>>>>>>>> Israel schreef op 5-9-2014 om 15:00:
>>>>>>>>>>> Hi Henk,
>>>>>>>>>>> What packages were upgraded on your system?
>>>>>>>>>>> Something like this command:
>>>>>>>>>>> awk '$3~/^upgrade$/ {print $4;}' /var/log/dpkg.log
>>>>>>>>>>> can get that info.
>>>>>>>>>>> On 09/05/2014 03:52 AM, Henk Terhell wrote:
>>>>>>>>>>>> The GUI has gone again after upgrades this week ...
>>>>>>>>>>>> Henk
>>>>>>>>>>>> Henk Terhell schreef op 2-9-2014 om 00:28:
>>>>>>>>>>>>> The upgrade received today on Lubuntu 14.10 has fully  
>>>>>>>>>>>>> resolved
>>>>>>>>>>>>> this
>>>>>>>>>>>>> problem.
>>>>>>>>>>>>> Nvida-304.123 works OK now.
>>>>>>>>>>>>> My thanks to the dev team.
>>>>>>>>>>>>> Henk
>>>>>>>>>>>>> Henk Terhell schreef op 1-9-2014 om 00:26:
>>>>>>>>>>>>>> After purging driver NVIDIA-304 I got my desktop back with
>>>>>>>>>>>>>> the
>>>>>>>>>>>>>> default nouveau driver.  However opening Firefox rapidly
>>>>>>>>>>>>>> caused a
>>>>>>>>>>>>>> screen freeze.
>>>>>>>>>>>>>> The older NVIDIA-173 did the same after installing and
>>>>>>>>>>>>>> rebooting. I
>>>>>>>>>>>>>> therefore switched back to NVIDIA-304.123 from the list and
>>>>>>>>>>>>>> again no
>>>>>>>>>>>>>> GUI...
>>>>>>>>>>>>>> So now I know (a) the absence of GUI was caused by the  
>>>>>>>>>>>>>> driver
>>>>>>>>>>>>>> and
>>>>>>>>>>>>>> (b) none of the recommended video drivers for Lubuntu 14.10
>>>>>>>>>>>>>> beta can
>>>>>>>>>>>>>> be used on this Geforce 6100 card.
>>>>>>>>>>>>>> For Lubuntu 14.04 (and 14.10 alpha) the recommended
>>>>>>>>>>>>>> NVIDIA-304.117
>>>>>>>>>>>>>> does not cause any problems.

Using Opera's mail client: http://www.opera.com/mail/

More information about the Lubuntu-users mailing list