Good news - Dell Dimension 2400 - Intel Graphics (also Dell DX-1100 Intel Graphics)

Aere Greenway Aere at
Sat Nov 15 22:02:17 UTC 2014

On 11/15/2014 11:53 AM, Ian Bruntlett wrote:
> Hi,
> I'm refurbishing an old Dell Dimension 2400. Whilst it has other, 
> non-lubuntu, issues, I can confirm that the GUI is fine. Details:-
> Dell Dimension 2400
> 768MiB RAM
> Intel Pentium 4 2.8GHz
> hostname banks
> Graphics: Intel 82845G/GL, kernel module i915
> BW,
> Ian
> -- 
> -- ACCU - Professionalism in programming -
> -- Free Software page - 
> -- My writing -

I posted this information for bug #1385920, but it may be useful for 
this e-mail list to see it.

The problem with the Dell DX-1100 machine is a different problem from 
this one.

Some release later than release 12.04, the Intel graphics on this 
machine performed poorly (jagged graphics gradients, a.k.a. tearing), 
and even the Java Web-Start (IcedTea) logo window failed to work on 
13.10 & 14.04.

Because of this, I took steps to use a different graphics card (a NVIDIA 
geForce 6200), in place of the Intel graphics that appeared to have been 
abandoned by Linux. Where the Dell DX-1100 machine has no AGP port, I 
used a PCI version of the NVIDIA card. To make it work, I had to set the 
BIOS to do "AUTO" graphics card selection, rather than using the 
on-board (Intel) graphics.

That worked, and I have been using it for some time. However, that 
particular machine I have been using for my 12.04 LTS system testing, so 
I stopped testing newer systems on it.

In collecting more information regarding this problem, I discovered that 
the Lubuntu 14.04 live CD system would not boot on this machine, which 
was a big surprise, since I thought this was only a problem with 14.10.

In experimenting with this machine, using different system levels, I 
discovered that if I used the Intel graphics card (setting the BIOS to 
use the 'onboard' graphics), the 14.10 live USB systems would not only 
boot, but that the problems with the Intel graphics have been corrected. 
I tried this with both Lubuntu 14.10 and ubuntuMATE 14.10, both of which 
worked with no problems (as long as I didn't try to use the NVIDIA PCI 
graphics card).

That was indeed a very pleasant surprise, for which I would like to 
thank the developers profusely! The Intel graphics _has not_ been 
abandoned, but is now supported, and has been fixed!  So I can take out 
the NVIDIA card, and everything will now be fine (well, I had a bit of a 
struggle getting my Windows partition to go back to using the Intel 
graphics, but I succeeded).

I do still have the problem of the Lubuntu 14.10 live system not booting 
on my Compac Deskpro 933 megahertz machine, which only has its very old 
Intel graphics).

The problem I posted for the Dell DX-1100, is actually a problem where 
if you boot the Live-DVD 14.10 system (both Lubuntu and ubuntuMATE), 
using a PCI (not AGP) NVIDIA card, with the BIOS graphics selection set 
to 'AUTO', it apparently goes ahead and uses the onboard (Intel) 
graphics card (which has no monitor connected to it), and ignores the 
NVIDIA PCI graphics card (which the monitor is connected-to).

It would be nice if this would work (since the NVIDIA has better 
resolution), but I can work-around the problem by just using the Intel 
graphics card.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list