14.04 seems subject to bug 1046563 with update-manager/notifier

John Hupp lubuntu at prpcompany.com
Thu May 15 18:44:49 UTC 2014

On 5/14/2014 10:21 PM, John Hupp wrote:
> Hi, Phill.
> I can be dense at any time of the day, and it's late here now, so the 
> risks are even higher.
> But: The Release Notes and links on that point (/etc/xdg/autostart 
> shortcuts don't work) seem both succinct and broad enough, but I'm not 
> seeing that they cover this case.  I can get update-notifier running 
> by several workarounds, but I never get a notification that updates 
> are available.  And it's not due to Phased Updates, because 
> update-manager shows many Security and Other updates available.
> If I'm missing your message on this, you'll have to reapproach.
> --John
> On 5/14/2014 6:51 PM, Phill Whiteside wrote:
>> Hi,
>> so the release notes do not state it can take two reboots (network), 
>> and the initial bug points to the second bug which affects (amongst 
>> other) update manager?
>> I'm not being picky, but I added that section and would appreciate 
>> how to make it clearer for those people who actually bother to read them.
>> Regards,
>> Phill.
>> On 14 May 2014 23:38, John Hupp <lubuntu at prpcompany.com 
>> <mailto:lubuntu at prpcompany.com>> wrote:
>>     For nm-applet, Fix #1 at
>>     http://www.webupd8.org/2014/04/fix-lubuntu-1404-network-manager.html
>>     worked for me, and Fix #2 slipped from memory.
>>     But for this problem with update-notifier, *neither* Fix results
>>     in notification of updates.
>>     Oddly, in /etc/xdg/autostart/update-notifier.desktop, neither
>>         Exec=dbus-launch update-notifier
>>     nor
>>         Exec="dbus-launch update-notifier"
>>     results in a running update-notifier process.
>>     If from the terminal I run
>>         $ dbus-launch update-notifier
>>     that produces a running process, but as in the previous post, I
>>     get no actual notification of updates.
>>     Which brings me back around to my current working theory that bug
>>     1046563 (concerning update-notifier) really is distinct from the
>>     nm-applet bug.
>>     On 5/14/2014 5:36 PM, Phill Whiteside wrote:
>>>     Hi John (and everyone else),
>>>     This issue is known about and is on the release notes[1]. It
>>>     never surprises me that people never read them :) If you are
>>>     affected, simply log onto the bug and click 'Affects Me', this
>>>     way you will get updates as the bug progresses. Rest assured,
>>>     Julien is on the case (look at the most recent posts).
>>>     Regards,
>>>     Phill.
>>>     https://wiki.ubuntu.com/TrustyTahr/ReleaseNotes/Lubuntu#Applications
>>>     On 14 May 2014 22:22, John Hupp <lubuntu at prpcompany.com
>>>     <mailto:lubuntu at prpcompany.com>> wrote:
>>>         On 5/13/2014 6:40 PM, brendanperrine wrote:
>>>>         On Tue, 13 May 2014 17:39:52 -0400
>>>>         Dale Visser<dale.visser at live.com>  <mailto:dale.visser at live.com>  wrote:
>>>>>         I may be seeing this as well on my two Lubuntu 14.04
>>>>         Also I think this may be a related issue but if I do update and then have a kernel update then the reminder to restart your computer does not come up.
>>>         OK, I found out that the first problem is that
>>>         update-notifier is supposed to launch from a shortcut in
>>>         /etc/xdg/autostart -- the same location that nm-applet is
>>>         supposed to launch from.  But it is well known that
>>>         nm-applet fails to launch from that location under 14.04. 
>>>         In fact, nothing will.  See Bug 1309698 - Lubuntu does not
>>>         handle /etc/xdg/autostart
>>>         <https://bugs.launchpad.net/ubuntu/+source/lxsession/+bug/1309698>
>>>         If one employs the same workaround as for nm-applet,
>>>         manually adding update-notifier as an autostart app, then
>>>         update-notifier appears as a running process.
>>>         *BUT*, I have not yet been prompted to install any updates. 
>>>         I understand that update-notifier is supposed to poll for
>>>         updates every 180 seconds.  So whatever was at work in
>>>         https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1046563
>>>         (starting with 12.04) seems to be failing here still.
>>>         Some of the Ubuntu-related servers seemed to be out of
>>>         commission earlier today, so maybe that comes into play also.
>>>         I see that some people have gotten results with
>>>         update-notifier.  I don't know what may be different here. 
>>>         This is on a laptop, so some default settings may be
>>>         different than for desktops.
>>>         ------------------------------------------------------------------------
>>>         On another point from my original post -- the difference
>>>         between updates offered by update-manager vs. apt-get -- I
>>>         found out that update-manager respects the Phased Updates
>>>         mentioned earlier by Dale Visser, and apt-get (and Synaptic)
>>>         do not.  They will offer everything that has been released. 
>>>         See bapoumba's post at Software Updater not notifying
>>>         <http://ubuntuforums.org/showthread.php?t=2222325&page=5&p=13018620#post13018620>,
>>>         though I don't know which of his three references he is
>>>         drawing that from.
>>>         ------------------------------------------------------------------------
>>>         @BrendanP: update-notifier is used to issue the reboot
>>>         reminder, so that is a related issue.
>>>         --
>>>         Lubuntu-users mailing list
>>>         Lubuntu-users at lists.ubuntu.com
>>>         <mailto:Lubuntu-users at lists.ubuntu.com>
>>>         Modify settings or unsubscribe at:
>>>         https://lists.ubuntu.com/mailman/listinfo/lubuntu-users
>>>         -- 
>>>         https://wiki.ubuntu.com/phillw 
>> -- 
>> https://wiki.ubuntu.com/phillw

I installed 14.04 on a desktop today, did not have it download updates 
as an installation choice, and then after booting into the finished 
installation, manually ran update-notifier to start the daemon.  It did 
not notify me about any updates.

Meanwhile, back on the laptop, it offered me updates *once* after I 
manually ran /etc/xdg/autostart/update-notifier.desktop modified with 
Exec=dbus-launch update-notifier.  I did not install any of the updates 
but simply X'ed out of Software Updater.  After a number of reboots, I 
have not been able to get it to offer me updates again regardless of the 
method I used to get update-notifier started.

By the way, I'm assuming that LXDE does something to modify the default 
behavior of the update-notifier daemon.  That is, by design it presents 
a tray icon (says the update-notifier readme and the Synaptic 
description).  But in Lubuntu, as far as I know there has never been a 
tray icon, but update-manager starts instead to offer the updates.  If 
someone knew about that mechanism it might provide a handle for more 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20140515/389e32c2/attachment-0001.html>

More information about the Lubuntu-users mailing list