AW: Multi-Processor Usage an Lubuntu 13.10 (64-bit) on MacBook

Nio Wiklund nio.wiklund at
Thu Oct 24 17:57:37 UTC 2013

On 2013-10-24 19:30, Aere Greenway wrote:
> On 10/24/2013 01:20 AM, Leszek Lesner wrote:
>> Tryout the terminal command
>> Cat /proc/cpuinfo
>> If this shows processor 0 and a processor 1 the system recognized two
>> CPUs and is using them.
>> The Qsynth through pulseaudio thing is bad as it had (from my
>> experience till pulseaudio 2.0) a bad latency. Use Alsa here instead
>> (needs to suspend pulseaudio first) and test again.
> I browsed (using the file browser) to /proc, and double-clicked the
> cpuinfo file. 
> It showed "Intel Core Duo 2" (something like that - I'm going from
> memory), and the number of cores was displayed as 1.  Information
> (options such as pae) was shown only for one CPU. 
> I then tried booting the Ubuntu 13.04 amd64 live CD. 
> When I hold down the Options key while powering up, with Ubuntu, there
> are two icons having the round CD icon at the right.  The first of those
> two, is labeled "Windows".   The second is labeled "EFI Boot". 
> I booted the Ubuntu 13.04 DVD using the first ("Windows") CD icon. 
> It came up, and ran fine, but system-monitor showed only 1 CPU, and the
> "/proc/cpuinfo" file agreed with that assessment.  There were no desktop
> hangs observed. 
> I shut it down, and (again holding down the "Options" key when it
> powers-up) this time I selected the "EFI Boot" CD icon at the far right
> of the list. 
> It immediately showed a text line saying secure boot was not available,
> and then presented me with a text menu with entries (as I recall):
> Try Ubuntu
> Install Ubuntu
> Check Disk for Defects
> I chose "Try Ubuntu", and it booted (eventually) directly into Ubuntu
> Unity desktop.  In this case, system-monitor showed two CPU's, and the
> "/proc/cpuinfo" file also showed two cores (and info/options about each
> of them). 
> However, after awhile running, the desktop hung, and I could not do
> anything further but power down (I did wait quite awhile for it to
> un-freeze). 
> I then tried the Lubuntu 13.10 amd64-mac live DVD, wanting to try the
> "EFI Boot" option, but only the "Windows" CD icon was available.  On
> booting this CD, only one CPU was available. 
> I also tried selecting rEFIt on power-up, and it showed the Linux
> penguin icon (for the Linux partition on the hard disk), and also
> another penguin icon at the far right, which when highlighted, indicated
> it was on CD (DVD).  I selected this (far right) icon, and booted it. 
> When it came up, it had only one CPU (the "/proc/cpuinfo" file indicated
> that the number of cores was "1").  The system did not hang in the time
> I was using it. 
> Regarding my use of PulseAudio, I install it so that I can access the
> Java Sound (Gervill) synthesizer.  If I don't load PulseAudio (and
> pavucontrol), I cannot use that synthesizer.  On all Ubuntu variants,
> the Java Sound synthesizer expects PulseAudio to be used. 
> When I re-configured Qsynth to use JACK, there were no more cut-outs on
> the sound.  But I (as always with Linux on this MacBook) would only
> produce audible sound with the laptop speakers - plugging in the
> amplifier cable into the headphone jack effectively shut off all sound. 
> -- 
> Sincerely,
> Aere
Interesting. It seems there are fundamental problems to run an Ubuntu
based OS on this computer.

Best regards

More information about the Lubuntu-users mailing list