Multi-Processor Usage an Lubuntu 13.10 (64-bit) on MacBook

Aere Greenway Aere at
Thu Oct 24 17:45:44 UTC 2013

On 10/23/2013 10:27 PM, Nio Wiklund wrote:
> When I have had similar issues, it has turned out, that I have been
> using a distro or version with a kernel without SMP support, so that is
> has been using only one kernel. I don't think that would be the cause of
> your problem, but I suspect, that the kernel does not recognize your
> hardware properly, and only activates on of the processors.
> Try live with some other versions and check if they show that both
> processors are running. You can also install and run htop to get a
> simple and straightforward display.

I tried booting the Ubuntu 13.04 amd64 live CD.

When I hold down the Options key while powering up, with Ubuntu, there 
are two icons having the round CD icon at the right.  The first of those 
two, is labeled "Windows".   The second is labeled "EFI Boot".

I booted the Ubuntu 13.04 DVD using the first ("Windows") CD icon.

It came up, and ran fine, but system-monitor showed only 1 CPU, and the 
"/proc/cpuinfo" file agreed with that assessment.  There were no desktop 
hangs observed.

I shut it down, and (again holding down the "Options" key when it 
powers-up) this time I selected the "EFI Boot" CD icon at the far right 
of the list.

It immediately showed a text line saying secure boot was not available, 
and then presented me with a text menu with entries (as I recall):

Try Ubuntu
Install Ubuntu
Check Disk for Defects

I chose "Try Ubuntu", and it booted (eventually) directly into Ubuntu 
Unity desktop.  In this case, system-monitor showed two CPU's, and the 
"/proc/cpuinfo" file also showed two cores (and info/options about each 
of them).

However, after awhile running, the desktop hung, and I could not do 
anything further but power down (I waited quite awhile for it to 

I then tried the Lubuntu 13.10 amd64-mac live DVD, wanting to try the 
"EFI Boot" option, but only the "Windows" CD icon was available.  On 
booting this CD, only one CPU was available.

I also tried selecting rEFIt on power-up, and it showed the Linux 
penguin icon (for the Linux partition on the hard disk), and also 
another penguin icon at the far right, which when highlighted, indicated 
it was on CD (DVD).  I selected this (far right) icon, and booted it.

When it came up, it had only one CPU (the "/proc/cpuinfo" file indicated 
that the number of cores was "1").  The system did not hang in the time 
I was using it.


More information about the Lubuntu-users mailing list