How to Change From SNA to UXA Acceleration Methods

Nio Wiklund nio.wiklund at
Thu Nov 7 17:08:04 UTC 2013

On 2013-11-07 17:56, Lee Gold wrote:
> On Thu, Nov 7, 2013, at 05:24 AM, Nio Wiklund wrote:
>> On 2013-11-07 13:04, Lee Gold wrote:
>>> Hi,
>>> Using Lubuntu 13.10.  Latest Flash plugin from repositories.
>>> I have an Intel Video Chip integrated on my motherboard. It's
>>> problematic and there are web pages devoted on how to make it work in
>>> Linux. It works OK with Lubuntu except for playing flash on youtube. For
>>> example, when trying to play youtube the video appears only green and
>>> purple and compressed into a small box. This is a know bug and a "fix"
>>> is to change the newer default acceleration method from SNA to the older
>>> UXA, then everthing works OK.
>>> The only way I know to do this is to generate an xorg.conf file, copy it
>>> to /etc/X11 and uncomment the Accelmethod line and edit it to "uxa",
>>> then reboot. I did this in Xubuntu previously and it worked. But I
>>> cannot get it to work in Lubuntu 13.10. I turn off X  and do # X
>>> -Confugre to make an xorg.conf file and do as cited above, put it in
>>> /etc/X11. But I either get a desktop with a very low resolution that
>>> can't be reset to higher normal user resolution or Lubuntu will not boot
>>> past the splash screen.
>>> So the fix that I see on many website for this is not working - an
>>> xorg.conf file to fix is not working. I know xorg.conf is not used
>>> anymore but I don't know any other way to fix it permanently.
>>> Any help appreciated.
>>> Lee G.
>> Hi Lee,
>> This works for me in Lubuntu 13.10 i386 (and is particularly useful with
>> old Intel graphics)
>> Edit (or create) /etc/X11/xorg.conf as follows: (there should be a tab
>> before each line except the first and the last).
>> Section "Device"
>> 	Identifier "Intel Graphics"
>> 	Driver "intel"
>> 	Option "AccelMethod" "uxa"
>> EndSection
>> Restart X (reboot, restart your display manager, whatever). Colors are
>> back to the way they used to be and flash works.
>> Best regards
>> Nio
> Hi,
> I've tried this already, but tried again. It did not work. The results
> seem exactly the same as the attempt I made in my previous email with
> trying /etc/X11/xorg.conf.d/20-intel.conf. Please see previous post, the
> same thing happened after reboot. The same log output but the line
> numbers grep are different i think:
> user1 at user1-pchut:~$ cat /var/log/Xorg.0.log | grep -i uxa
> [    19.680] (**) intel(0): Option "AccelMethod" "uxa"
> [    20.033] (II) UXA(0): Driver registered support for the following
> operations:
> user1 at user1-pchut:~$ 
> I get the impression that maybe X config begins but when doing things
> with a config in /etc/X11 it causes some steps that need to be taken to
> be skipped or missed during boot. I say this because X is there but it
> is not working 100% OK. maybe a fix is to some additional things after a
> boot? Are all my services for X working like lightdm, could that be it?
> How to check?
> What additional info can I give? These fixes suggested are documented to
> fix and I've tried them but for some reason it's not working. 
> Thanks
> -----
Hi Lee,

I think the support for your graphics chip/card was dropped somewhere
after 12.04. You might try some more tweaks, but you may have to give it up.

Fortunately there is still 12.04 LTS. Even if Lubuntu 12.04 has passed
end of life, you can run Ubuntu based

- Xubuntu (LTS until April 2015), and
- LXLE, Precise Gnome Classic Tweaks and Bodhi (LTS until April 2017)

to mention a few flavours/distros, that have long time support and might
work well with your hardware.

Best regards

More information about the Lubuntu-users mailing list