Live Disc with Persistence

John Hupp lubuntu at
Mon Aug 12 18:57:55 UTC 2013

On 8/11/2013 12:33 PM, John Hupp wrote:
> I have 4GB and 8GB flash drives currently serving as Live USB drives 
> with persistence running Quantal and Saucy.  For the sake of 
> troubleshooting the Flash/LightDM-login problems more invasively, I 
> would like to make another Live setup with persistence running Raring, 
> but I don't have another bigger flash drive on hand.
> But I do have several 1GB flash drives.  I tried making a Live USB 
> with one of those, setting persistence storage to 100MB (via 
> UNetBootin).  But when I tried to use it I kept getting 
> no-space-available sorts of errors.  So I concluded that 1GB was too 
> small to serve both for the Live USB and the persistence storage. 
> True?  (Though I think I observed after the fact that UNetBootin had 
> preserved some files and folders that were already on the drive, so 
> maybe I just need to try again after deleting everything or formatting.)
> I then tried to set up a Raring Live DVD with persistence using either 
> a flash drive or the internal hard drive, but so far have failed.
> In one case I used Gparted (I don't know where I was using that, since 
> I don't now find it in the installed version of Raring) to create a 
> single ext3 partition labeled casper-rw to serve as the persistence 
> storage, but that didn't work for me.
> For two other cases I began by running in a terminal:
>     dd if-/dev/zero of=casper-rw bs=1M count=768
>     mkfs.ext3 -F casper-rw
> Then I copied the resulting casper-rw file both to a flash drive and 
> to the hard drive, but booting with the Live disc and either of those 
> running did not result in successful persistence.
> Can anyone see what I was doing wrong?

I tried again to make a Live USB with persistence, all on the 1GB stick, 
this time after reformatting (FAT32) and then setting only 50MB for 
persistence in UNetBootin.  And it did have persistence (as in my 
earlier attempt), but 50MB doesn't seem to be enough to do much.  Trying 
to Reload Synaptic, it again yielded the "no space left on the device" 

I also tried again to get to a workable Live DVD with persistence on a 
USB flash drive.  In Gparted, I deleted the existing partition, created 
a single FAT32-type partition labeled "casper-rw," then formatted the 
partition as FAT32.  I booted to the Live DVD with the flash drive 
inserted (choosing F6 Options and adding " persistent" to the boot 
string), made some changes, rebooted again the same way and found that 
the changes had not been saved.

So apparently I'm still missing something.

More information about the Lubuntu-users mailing list