Problems Updating Lubuntu 12.04, 12.10, and 13.04 on Slow Machines

Ali Linx (amjjawad) amjjawad at
Sat Apr 13 18:26:48 UTC 2013

Dear Aere,

I'm really sorry, I couldn't read each and every word because this is
indeed a very long email but I did get the idea :)

Please, read this carefully:

1- When you have LESS than 1GB RAM, SWAP Partition MUST be as twice as your
RAM. Having that said, Your SWAP Partition in your case MUST be 1GB. This
is from long experience not from a Wiki Page :)

2- You need to understand that whether you are using the Terminal or the
Update Manager, these two are the same :) one is CLI and the other is the
graphical front end and both do the same thing.

3- You need to understand that "sudo apt-get upgarde" does not upgrade
Linux Kernel. For that, you need: "sudo apt-get dist-upgrade".

Now, please, follow these steps:

1- Make sure your SWAP is 1GB at least.
2- From LXTerminal or whatever Terminal you are using, please run:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get autoclean

Make sure to close ALL the other applications
Each command at a time.

3- If your machine have a LAN/Wired connection, you can run the above
commands from CLI without logging to your Desktop.

Type your Username and Password
then run the above commands

4- Please, post here the output of at least two commands (apt-get update
and apt-get upgrade).

5- That is all :)

Thank you!

On Sat, Apr 13, 2013 at 9:28 PM, Aere Greenway <Aere at>wrote:

> All:
> I have been observing a problem where on slow (450 megahertz) machines,
> the software updater window disappears, and the updates are applied in the
> background, with no notification of completion.
> I tried applying updates using terminal commands:
> sudo apt-get update
> sudo apt-get upgrade
> These would start out with me being able to see what was going on, but it
> would come back to the command prompt during the trigger processing (and
> new commands could be entered), while processing continued in the
> background.  Again, there was no notification of completion.
> More updates were available recently, so I tried it again on my 450
> megahertz machine.
> I used the terminal commands (as above), and the output was encouraging,
> because I could see the progress of what was going on.
> But then it got to the mkinitramfs step, and control returned to the
> command-prompt (I could enter commands), without it proceeding farther.
> Repeating the "sudo apt-get upgrade" step responded with something about
> the (new kernel) change being "held-back".
> This made me lose all trust in the terminal method of updating, because
> when I apply updates, I want them all to be applied - not just some of them.
> So I ran the software updater, and it showed that the kernel update still
> needed to be applied.
> The cursor on the software updater window showed as being busy, and stayed
> that way for a long time.  I clicked the "Apply Updates" button (or
> whatever it is called), but that never seemed to get going, and at one
> point the software updater crashed.
> I was hopeful I could submit a crash report, but updating appeared to be
> going on in the background, and apport was consuming a lot of memory, to
> the point that constant swapping started to occur.  I finally (reluctantly)
> had to kill the apport task, and (eventually) the software updater task as
> well.
> At this point, I feared I had lost this particular system.
> On rebooting, if I ran the software updater, it showed that the kernel
> updates still needed to be applied, but the cursor on the software updater
> window remained busy, for a really long time.
> A check of the Task Manager window showed Update Manager using time, as
> well as apt-check.
> Remembering an earlier e-mail about an apt-check (correction - that e-mail
> said "dpkg") needing to complete (and taking as long as 90 minutes to do
> so), I left it running, and went to do something else.
> When I returned a half-hour later, the CPU-usage was back to an idle
> state, and the cursor (when on the software updater window) was no longer
> 'busy'.
> So I clicked the "Apply Updates" button, and 30 seconds or so later, I was
> presented with a dialog box to enter my password, which I did.
> But as before, after awhile, the software updater window disappeared.
> But the Task Manager window showed processes running that I could identify
> as part of the updating process (such as mkinitramfs), so I just watched it.
> Eventually (after a long time), the CPU-usage went back to an idle-state.
>  Again, there was no notification of completion.
> When I ran the software updater at that point, it (after checking for
> updates) said that a reboot was required for updates to finish, which I
> proceeded to do, and now the system appears to be properly updated.
> That's a long story, but with some precision in the description of what
> happened.
> So anyway, here is my description of the problem, and what ought to happen:
> Problem:
> On slow machines (450 megahertz, single-processor, 512 meg RAM), when you
> run the software updater, the software updater window disappears, yet
> updates seem to get applied in the background. There is no notification of
> the completion of this process.
> 1. The software updater window should not disappear.  It should be
> possible to monitor the progress of applying the updates.
> 2. There should be some notification of the completion of the update
> process, if for some reason it /has/ to run in the background.
> 3. There is a lengthy step performed by the software updater (apt-check)
> which runs for a long time (30 minutes, for example). While it is running,
> the software updater is not actually usable. If you click the "Apply
> Updates" button during this time, you only cause more problems.  There is
> no progress-meter display.  The application appears to be hung.  CPU-usages
> is at 100%, so it appears the system is hung.  This should not happen -
> really.
> Summary:
> On slow machines, the method of applying software updates is broken, and
> not something an ordinary user can deal with, or use with any real chance
> of success.
> If you can't update your system, then you system is not supported -
> despite what the website may claim.
> I have submitted a bug-report for this, but it has been declared "invalid"
> because my machine doesn't have a speed of 1 gigahertz, with 1 gigabytes of
> RAM - despite the fact that I was using Lubuntu.
> Here is a link to the bug-report:
>**bugs/1159589<>Title: When applying software updates, updater window disappears
> --
> Sincerely,
> Aere
> --
> Lubuntu-users mailing list
> Lubuntu-users at
> Modify settings or unsubscribe at:**
> mailman/listinfo/lubuntu-users<>

*Best Regards,
Lubuntu One Stop Thread <>| My
Launchpad <> | My Ubuntu Forum
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list