Help to get USB WiFi RTL8187 working

Lee Gold leegold at
Sat Nov 10 05:04:52 UTC 2012


Using Lubuntu 12.04. 

I can not get an external USB WIFI rtl8187 interface to work. These
units really pull a signal in but I've always had problems with them and
recent Ubuntu flavors. Wlan0 is the builtin one in my laptop which works
OK. wlan1 is the USB trl8187. I turn off via harware switch on my laptop
the builtin one. Then try to turn on the USB, nothing seems to work. I
tried # sudo ifconfig wlan1 up but the LED on the rtl8187 will not light
up. When I do $ lsmod I see plenty of mention of rtl8187 and tried
adding rtl8187 to /etc/modules, but the LED on it will not light.
ifconfig "sees it" as wlan0. Network Manager cites it but it's grayed

When I give up and use the built-in intel 4965 I hit the hardware button
for it and along with the builtin's LED the rtl8187's now also lights up
- for some reason it only lights when the builtin is activated!

USB rtl8187 used to work in older versions, I'm sure I remember it
working in 10.10, and it'll work in special Linux flavors made for wifi
hacking like Blackbuntu. But recently it's been shaky for me with most
newer Ubuntus.

Is there a way to get it working?


-- - Same, same, but different...

More information about the Lubuntu-users mailing list