Java and Firefox 3.6

Kaj Haulrich kaj at
Sun Mar 21 20:41:20 UTC 2010

Nigel Ridley wrote:
> I just noticed that according to about:plugins I don't have the java plugin installed.
> I do have the sun-java-plugin installed and so tried the following:
> nigel at nigel:~$ sudo  ln -s 
> /usr/lib/jvm/java-6-sun- 
> /usr/lib/firefox-addons/plugins
> [sudo] password for nigel:
> nigel at nigel:~$ sudo  ln -s 
> /usr/lib/jvm/java-6-sun- /usr/lib/firefox/plugins
> nigel at nigel:~$
> [above code is broken up by mail client's line wrap]
> Restarted Firefox (Namoroka actually) but still no java.
> On checking the various firefox dirs I do have symbolic links in all the plugin dirs.
> How does one get java working?
Your procedure seems all right, only java is outdated. the 
current version is - but is not available in the repos (as far 
as I can see).

In order to use various web-services - like home banking etc. - I 
recommend updating to the current version via Sun's site.

The procedure is as follows:
1) Uninstall all your java apps.
2) Download the *.bin file from Sun
3) sudo mkdir /usr/lib/java
4) Move the downloaded *.bin file to /usr/lib/java
5) cd /usr/lib/java
6) sudo chmod a+x *.bin
7) sudo ./*.bin  (the java-bin)
8) wait a bit and enjoy all the files unfold
9) scroll down and accept the license

Now it gets hairy, but here is one method:

10) [Alt]+[F2] then type: kdesu dolphin
11) Navigate to /usr/lib
12) Split the screen
13) In the left pane navigate to /usr/lib/java/jre1.6.0_18/lib
14) if you're 32-bit, then to ./i386 - otherwise ./amd64
15) In the right pane, navigate to i.e. /usr/lib/mozilla/plugins
16) With your left mouse-button drag to the right pane and 
choose "link here".
17) Eventually, do the same to other browsers plugins directories
18) Eventually, delete the original, downloaded *.bin file
19) Open a browser and check here:
20) Enjoy.

Kaj Haulrich.

More information about the kubuntu-users mailing list