help with adept_manager lock

Willy Hamra w.hamra1987 at gmail.com
Wed May 13 11:43:53 BST 2009


2009/5/13 Goh Lip <g.lip at gmx.com>:
> Goh Lip wrote:
>> Patricia Wilson wrote:
>>
>>> On Tue, May 12, 2009 at 9:42 PM, Goh Lip <g.lip at gmx.com> wrote:
>>>
>>>> Patricia Wilson wrote:
>>>>>      >     Patricia Wilson wrote:
>>>>>      >      > When I try to use adept_manager to do the upgrade to 9.04
>>>>>     I get
>>>>>      >     an error
>>>>>      >      > message -- Unable to get exclusive lock
>>>>>      >      > With detail --
>>>>>      >      > This usually means that another package management
>>>>>     application (like
>>>>>      >      > apt-get or aptitude) already running. Please close that
>>>>>      >     application first.
>>>>>      >      >
>>>>>      >      > I had the system go down during a prior attempt to do the
>>>>>     upgrade and
>>>>>      >      > suspect that there may be a lock file somewhere that
>>>>>     didn't get
>>>>>      >     cleaned
>>>>>      >      > up. Can anyone help me find that/those  lockfile(s)?
>>>>>      >      >
>>>>>      >      >
>>>>>      >
>>>>>      >     Try
>>>>>      >
>>>>>      >     sudo dpkg --configure -a
>>>>>      >
>>>>>      >     or
>>>>>      >
>>>>>      >     sudo apt-get install -f
>>>>>      >
>>>>>
>>>>>
>>>>>      > I tried both and am still getting the same error.
>>>>>
>>>>>     Have you exited Adept or Synaptic or whatever when you do this?
>>>>>
>>>>>     Note: please bottom post,(meaning write your reply below the
>>>>>     quotes).
>>>> I
>>>>>     have to rearrange your messages so others can get some sense of the
>>>>>     messages.
>>>>>
>>>>> Yes, I just tried running both after a reboot and I still get the lock
>>>>> error from adept_manager. I am running adept_manager from the command
>>>>> line and get a lot of messages in  the terminal window but none seem
>>>>> relevant to this issue. Also, I am running from gnome not KDE.
>>>> Thanks for bottom posting.
>>>> When I mentioned exit from Adept or Synaptic, it means don't use the
>>>> program, close, quit or whatever term you can understand. Don't use
>>>> adept_manager. Close, quit, exit. Then, on a terminal, console or bash,
>>>> type "sudo dpkg --configure -a" or "sudo apt-get install -f"  without
>>>> the quotation marks.
>>>>
>>>> If you are using Gnome, why are you using Adept?
>>>>
>>>>
>>>> Good question. I was following the instructions at
>>> https://help.ubuntu.com/community/JauntyUpgrades/Kubuntu/8.04.
>>>  Here is what I did from a fresh terminal (in a KDE session) after a
>>>  reboot:
>>>
>>> Leothon/home/pwilson> sudo dpkg --configure -a
>>> Leothon/home/pwilson> sudo apt-get install -f
>>> Reading package lists... Done
>>> Building dependency tree
>>> Reading state information... Done
>>> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>>> Leothon/home/pwilson>
>>>
>>> Then I opened adept_manager from the KDE menu and selected Fetch Updates.
>>> Then when it appeared I selected Version Upgrade. Then after going through
>>> a few forms I get the Unable to get exclusive lock error.
>>>
>>> I very much appreciate the time you are taking with this and I hope I am
>>> understanding you correctly.
>>>
>>
>>
>> Good. " 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded." is
>> good. WITHOUT opening adept OR Synaptic, at the terminal, type in
>> sudo apt-get update
>>
>> When done...., type in
>> sudo apt-get upgrade
>>
>> I am not sure running Adept in Gnome affects anything. Most of here don't do
>> this. In fact, some here prefer Synaptic to Adept when using KDE. And
>> Kpackage still has some problems. Most here prefer aptitude.
>> Well... whatever works.
>>
>> Regards,
>> Goh Lip
>>
>> It doesn't matter if the cat is black or white,
>> As long as it catches mice.
>>            -  -Deng XiaoPing
>
>
> Patricia, sometimes too little information given is bad. We work based
> on some common assumptions. If you have uncommon situations, please
> state right at the beginning, like using Gnome instead of KDE, upgrading
>  from 8.04 instead of 8.10. Are you trying to upgrade to Kubuntu 9.04
> while still on the Ubuntu desktop? Are you by chance using KDE3.5
> instead of KDE4 in your 8.04? And why upgrade from the Gnome desktop?
>
> If any of the above is true, you may run into unnecessary problems
> trying to upgrade to Kubuntu 9.04.
>
> I have often found that it is simpler, cleaner and faster to do a fresh
> reinstall. To me, installing Kubuntu is the easiest installation
> compared to many other OS's, Windows or other Linux distro's.
>
> Of course, there are some experts who can work around the many issues
> that would crop up if you choose to upgrade from the KDE3.5  Hardy or
> from Gnome desktop. But I am not one of them.
>
> If this is the case, you might want to do a fresh reinstall.
> Please back up your /home first. That is all you need to back up.
>
>
>
> note: if you still want to try to upgrade from Gnome 8.04 to Kubuntu
> 9.04, try to do this ....
>
> Uninstall kubuntu -desktop, purge. (assuming you are running KDE3.5)
> At ubuntu -desktop, upgrade to ubuntu 9.04. (don't use adept, it won't
> be there)
> When you have a running Ubuntu 9.04, (then and only then) install
> kubuntu-desktop.
>
> Regards,
> Goh Lip
>

i think there's no problem at all for upgrading from GNOME. it's one
ystsem after all, she has 2 DEs and she wants both of them i'll
assume, she might even have personalisations in both that she don't
want lost. when it comes to adept, that might be a problem. even
though i used adept and it worked perfectly for my hardy->intrepid
upgrade in the past, it still might cause trouble with weird cases,
and for random reasons. IMHO synaptic is far superior, and since
you're in GNOME that's another reason for you to use it. or if you
prefer, the update-manager program, which you can use in a shell.


-- 
Willy K. Hamra
Manager of Hamra Information Systems
Co. Manager of Zeina Computers and Billy Net.



More information about the kubuntu-users mailing list