Can't get wireless to work with kubuntu 9.04

Bruce Bales bbales at
Fri Jul 31 18:19:06 UTC 2009

On Thursday 30 July 2009 23:44:08 Nils Kassube wrote:
> Bruce Bales wrote:
> > Wireless on my laptop with kubuntu 8.04 was not easy.  I had to
> > sudo iwconfig ath0 essid bbs key (the wep code)  and then
> > sudo dhclient each time I booted up.
> >
> > Then I upgraded to kubuntu 9.04 and the iwconfig line no longer
> > works.  The iwconfig line gives me "ath0 no such device."
> > I tried wlan0, wlan, eth0, ath1 and wlan1 -- same result.
> What wireless device do you have? I think "ath0" would be some Atheros
> chipset but which one? 8.04 had the madwifi driver but now the driver is
> in the kernel, maybe your chipset is not yet supported correctly? To
> find out what chipset you have, use the commands
> lspci
> sudo lshw -C network
> in a terminal and post the relevant part of the output. And if you want
> to find out the wireless interface name you can try the command
> ifconfig -a
> in a terminal. It will show you the configuration of all interfaces
> known to your system.
> > The main page has an icon which says "network management"  Clicking
> > on that then  "network connection" then "enable wireless"  then
> > "manage connection" gets me nowhere.
> If you have problems getting the network manager working it may be
> useful to replace it with wicd. You can install the wicd package from
> the 9.04 repository.
> Nils

Thanks for answering, Nils.
lspci shows that most of the drivers are Intel 82801, but the ethernet 
controller says "Atheros Communications Inc. Atheros AR5001X+ Wireless 
network Adapter (rev 01)"

lshw -C gives me network 0 and 
       description: Wireless interface
       product: Atheros AR5001X+ Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 2
       bus info: pci at 0000:02:02.0
       logical name: wmaster0
       version: 01
       serial: 00:11:f5:1e:f1:57
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath5k_pci latency=168 maxlatency=28 
mingnt=10 module=ath5k multicast=yes wireless=IEEE 802.11bg
  *-network DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: pan0
       serial: f6:79:e3:77:14:18
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 
firmware=N/Alink=yes multicast=yes

The pertenant part of ifconfig -a is
wlan0     Link encap:Ethernet  HWaddr 00:11:f5:1e:f1:57
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

How can I get the proper driver for this machine?


More information about the kubuntu-users mailing list