Can't get wireless to work with kubuntu 9.04

Nils Kassube kassube at
Fri Jul 31 16:23:02 UTC 2009

David McGlone wrote:
> > > > Bruce Bales wrote:
> > > > > Wireless on my laptop with kubuntu 8.04 was not easy.  I had
> > > > > to sudo iwconfig ath0 essid bbs key (the wep code)  and then
> > > > > sudo dhclient each time I booted up.
> > > > >
> > > > > Then I upgraded to kubuntu 9.04 and the iwconfig line no
> > > > > longer works.  The iwconfig line gives me "ath0 no such
> > > > > device." I tried wlan0, wlan, eth0, ath1 and wlan1 -- same
> > > > > result.

> I thought on an upgrade, the file shouldn't have been modified. He
> stated it worked in 8.04. In other words his interfaces file should
> have already been set correctly for his interfaces, since he had
> already had it working in 8.04.

OK, now I see your line of thought. Actually it doesn't work because the 
device ath0 no longer exists but IIRC there is no entry in the 
interfaces file necessary to get the device. It should exist as soon as 
the kernel finds the card.

>  But I made the suggestion because, I had the same problem on my
> upgrades where my settings would disappear in my interfaces file.

That's interesting because I have a static setup on my desktop machine 
and the interfaces file survived the upgrade from 8.04 to 9.04 without 
change. OTOH there is no wireless card in that machine, so maybe only 
wireless settings would be removed? And on my laptop the file is 
untouched as well but there were only some old additional comment lines 
left from previous wireless experiments.

> I tried using knetworkmanager (or whatever it's called) to configure
> my interfaces again but the interfaces file never did get the data
> written to it.
> I've also did fresh installs on 3 computers for people last week and
> I had to manually add the eth* interfaces to the file because
> knetworkmanager just wouldn't write to the file.

Knetworkmanager (or whatever it's called) never writes to the interfaces 
file. It is a program that keeps the settings somewhere in your $HOME 
directory and then activates the wireless interface after login. As it 
is a program run as unprivileged user it can't write to 
/etc/network/interfaces which is owned by root.

> I can understand the file being empty except for lo on a fresh
> install, but on an upgrade.....

Granted, on an upgrade the interfaces file should be left unmodified. 
But keep in mind that interfaces listed in /etc/network/interfaces will 
be ignored by knetworkmanager or its Gnome cousin. That's why the file 
nowadays only has the lo entry.


More information about the kubuntu-users mailing list