no sound after?

Goh Lip g.lip at
Sun Jul 26 19:25:31 UTC 2009

Perry wrote:
> Hi,
> I have been battling for days with sound problem. I made many reinstall to pin 
> down the cause, rebooting after each operation.
> I checked kmix, the strange thing is it has no button under would 
> take me another reinstall to check wether it dissepeared or newer was there, 
> unless someone can confirm there is no button there.
> I tried renaming .kde to no avail.
> *Symptoms*
> On fresh install KUbuntu Hary I have the "greeting sound" when I log in.
> I can reboot, change screen from p&p to generic, reboot, install Firefox with 
> adept, reboot...and still have the greeting sound. (Warning: /home partition 
> was not reformatted)
> What appeared once to kill it was when I watched some dailymotion stuff on 
> firefox.
> I could then "ctrl-alt-backspace" and still get the greeting sound, but it is 
> was gone after a reboot.
> I thought I had it!
> But on another trial I installed the updates first, rebooted and the sound was 
> gone on next (compulsory because of kernel) reboot.
> It is not that I care about this sound, but I have no sound at all.
> There is a lot of documentation on sound problem, but very little pertinent 
> for my problem, and nothing I tried worked.
> I can list the output of some commands, but I'm unsure it will help until I 
> understand what causes the sound to dissepear.
> Any idea?
> P.S. I thought it was wise to install the LTS Hardy, I tried Kubuntu 9 on 
> another partition, liked it less, but it still has sound working.
> Would you advise me to to use Kubuntu 9 instead of Hardy?
> Thanks for any pointer or opinion.
> Perry
> ------------------------------
> perry at Lincu:/var/tmp$ aplay -l
> **** Liste des PLAYBACK périphériques ****
> carte  0: NVidia [HDA NVidia], périphérique 0 : ALC883 Analog [ALC883 Analog]
>   Sous-périphériques: 1/1
>   Sous-périphérique: #0: subdevice #0
> perry at Lincu:/var/tmp$
> -------------------------
> perry at Lincu:/var/tmp$ aplay -L
> default:CARD=NVidia
>     HDA NVidia, ALC883 Analog
>     Default Audio Device
> front:CARD=NVidia,DEV=0
>     HDA NVidia, ALC883 Analog
>     Front speakers
> surround40:CARD=NVidia,DEV=0
>     HDA NVidia, ALC883 Analog
>     4.0 Surround output to Front and Rear speakers
> surround41:CARD=NVidia,DEV=0
>     HDA NVidia, ALC883 Analog
>     4.1 Surround output to Front, Rear and Subwoofer speakers
> surround50:CARD=NVidia,DEV=0
>     HDA NVidia, ALC883 Analog
>     5.0 Surround output to Front, Center and Rear speakers
> surround51:CARD=NVidia,DEV=0
>     HDA NVidia, ALC883 Analog
>     5.1 Surround output to Front, Center, Rear and Subwoofer speakers
> surround71:CARD=NVidia,DEV=0
>     HDA NVidia, ALC883 Analog
>     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
> null
>     Discard all samples (playback) or generate zero samples (capture)
> perry at Lincu:/var/tmp$         
> -----------------------------------------------
> perry at Lincu:/var/tmp$ dmesg | less   
> 		I only spotted: 
> [   35.183455] ata4: SATA link down (SStatus 0 SControl 300)
> [   35.198543] Driver 'sd' needs updating - please use bus_type methods

Perry, at this time, let's just go through only one item, ie., the PCM 
issue which made me feel like a complete idiot. :)

I take it you have video in youtube at firefox but no sound;

Do you have the Kmix icon at the system tray?
If not, open command and enter 'kmix'
LEFT click on the icon and click 'mixer' button.
Do you see a channel with PCM?
If no, at the settings, click configure channels.
Then tick PCM button. You're done.
Make sure you slide up the volumn level up, too :)

Goh Lip

note: if this is not the issue, let's tackle this some other time.
I need to take about 8 hrs off.

More information about the kubuntu-users mailing list