Print server for dual environment

Bruce Marshall bmarsh at
Wed Jul 15 02:18:26 UTC 2009

On Tuesday 14 July 2009, Kevin B. O'Brien wrote:
> I tried setting it up as a socket on port 9100, which one person
> (Terrell Prude Jr.) suggested worked great for him. For me, not so much,
> that is what gave me the "broken pipe" error. I then tried doing what
> the manual suggested, using the URL "lpd://", and
> the error I get now is "/usr/lib/cups/backend/lpd failed". Now, there is
> some kind of executable file, looks like a binary, at this location, so
> it is not a missing file kind of problem. I suspect I am probably
> overlooking something that is probably obvious to more experienced
> people like you, but I don't know what it is. So I am asking for some help.

Ok,,,   you should set it up in CUPS, and as long as it truely will talk on 
the network (and Windows isn't making it sick) then it should work fine.

In your browser,   type in the link:     localhost:631

That should get you a nice page for defining a CUPS printer.

Click on  'Add Printer'

For a name, use   lp       (a pretty standard name)
Location:    <wherever>
Description:   <Trendwhatever  Modelnumber>


Device:   AppSocket/HP JetDirect


Device URL:    socket://   Use your IP addresses for the 


Now you have a problem, because I do not see your printer in the vendor list.  
You may have to dig on this one... or get a PPD file off windows, but I've 
never done that.

Beyond this, you pick a model for the printer and then you are done.

Sorry I couldn't take you all the way to the end.

More information about the kubuntu-users mailing list