Using Konsole, how do I get my computer to recognize my new Card Reader.

Nils Kassube kassube at
Tue Jan 27 14:02:14 UTC 2009

Steven Vollom wrote:
> I have gotten my computer to recognize the card reader using the GUI,
> which was a great accomplishment for me, however, I am wanting to
> become able to use the shell for such things.  Hardy KDE 3.5.10
> To get it recognized in the gui, I opened Kmenu>System
> Settings>Advanced Tab>Disk&Filesystems>Highlighted 1 Partition 982.4
> Mb/Device/dev/sdc1.  It showed as auto for Type.

As I understand it, that is the place where you manage your fstab entries. 
IMHO, a card reader should better not be included in /etc/fstab because it 
contains removable media. These media should be available to the current 
user without any extra effort by the administrator. A better GUI way to 
find the card reader would be "system menu" -> "storage media". BTW: The 
system menu is the icon to the right from the K menu in the system tray 
of a default installation.

> The only option at the bottom of the screen, after entering
> Administrator Mode, was New, so I clicked on New.  For <mount point> I
> chose /media/sdc1, and for permissins chose everyone.  When I clicked
> on OK, the mount point was set as instructed and it showed as disabled.
>  I then clicked on the Enable option at the bottom of the window and
> closed the package.
> This worked so I know it is one way of getting the job done, however,
> when I attempted to first locat the sdc1 device using the shell, I
> failed.
> First I opened /root/media to see if the reader showed there, it did
> not.  

No, it can't be there, it would be in /media/sdc1 instead because that is 
the mount point you chose. If you want to find out where a partition is 
mounted use the mount command without parameters. It shows the devices 
and mount points for all mounted partitions.

> I attempted various addresses, like /system 
> settings/advanced/disk&filesystem, and failed.  

There is no directory /system settings/advanced/disk&filesystem (unless 
you created one). The GUI menues have no relation to the actual file 
system which is what you see at the command line.

> I tried /dev/sdc1 and failed.

Well, /dev/sdc1 should have existed because that is what you found with 
the GUI. However it is NOT a directory where you can read or store files. 
It is the device entry for this particular partition. You are not allowed 
to read directly from that device because you could read data which 
should not be visible to all users due to the permissions of particular 
files stored on the file system of that device. And you are not allowed 
to directly write to the device either because you would destroy the file 
system on the device. So the only way to access the device is if it is 
mounted somewhere in your file system tree.

If you want to mount removable media like USB sticks or card readers from 
the command line, I would suggest you install the package pmount which 
gives you the commands pmount and pumount. Then you would mount the sdc1 
partition with the command

pmount /dev/sdc1

and don't use sudo for this command. Then the partition will be mounted 
to /media/sdc1 even without an entry in /etc/fstab. If you don't know 
which partitions are available use

ls /dev/sd*

to see all of the devices. Only those devices with a number at the end are 
mountable partitions. Before you unplug a device, use the command

pumount /dev/sdc1

and wait for the command prompt before you unplug it to make sure that all 
files are written to the device.


More information about the kubuntu-users mailing list