java/firefox works but "which java" returns nothing

Perry pwhite at
Sat Dec 26 08:38:36 UTC 2009

Le Friday 25 December 2009 22:12:54 Jonas Norlander, vous avez écrit (you 
wrote) :
> 2009/12/25 Perry <pwhite at>:
> > Le Friday 25 December 2009 17:46:00 Jonas Norlander, vous avez écrit (you
> >
> > wrote) :
> >>  I think what you look for is update-java-alternatives
> >>
> >> / Jonas
> >
> > Thanks for quick answer,
> > but that is "unknown command". Did you mean
> > update-alternatives --config java ?
> No I do have update-java-alternatives (don't know what package it
> belong to though). This box is Xubuntu 9.10 upgraded from 8.04. Java
> has for most of the times worked for me, I did have some trouble in
> 7.xx when I had both SUN and OpenJDK but a "update-java-alternatives"
> or similar fixed it. You could try to reinstall java for something is
> obviously not right for you.
> / Jonas
Thanks, that helped,

I didn't have "update-java-alternatives", probably because I installed the bin 
from Sun.
Upon installing java from repos I believe the alternatives were automatically 
Both FF and Konq say I have the latest java version installed and FF can 
display map24 in a separate window.
Map24 worked in Konq under Hardy but newer in Jaunty or Karmic, I can live 
without is just that I'm trying to understand why.

Cheers		Perry

BOFH excuse #126: it has Intel Inside

More information about the kubuntu-users mailing list