Printing Problem

Bruce Marshall bmarsh at bmarsh.com
Thu Oct 2 16:25:06 BST 2008


On Wednesday 01 October 2008, Pastor JW wrote:
> On Wednesday 01 October 2008 7:45:27 pm tom bell wrote:
> > Just wondering here if you have used your browser to address CUPS via:
> > http://localhost:631
>
> Yes, I have but the laptop can not find the computer with the printer which
> is on the same router as the laptop.  Neither can the other two wired
> desktops for that matter.

Something is seriously wrong then.

I have a labrat machine here that has a scanner connected to it.  I just now 
wanted to copy a piece of paper but found out that I hadn't defined a printer 
for that machine.

Went into 'system settings',  selected 'add printer',  told it I wanted to add 
a 'network printer'  using TCP,  gave it the address,  and port (9100)  and 
told it what kind of printer it is (HP4000TN)  and off it went.  Printed the 
CUPS test page just fine.

It shouldn't be harder than that.

Now if you are trying to print from one linux machine to another, and that 
other has a local printer, then you need to add a 'remote CUPS server' 
printer (IPP/HTTP)  and use 'anonymous' as the user ID type and give it the 
host IP address and use port 631.

But you may have to make some settings on the machine with the printer also.  
I just tried to have my labrat machine talk to a different linux machine by 
doing the above remote CUPS server setup and it says "unable to connect to  
xxx.xxx.xxx.xxx on port 631"

Looking at the /etc/cups/cupsd.conf on my server machine I see the setting to:

# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock


And there may be other things that need to change.   I did all this 7 years 
ago and it worked fine.  Don't need to do it anymore.



More information about the kubuntu-users mailing list