ndiswrapper questions

D. R. Evans doc.evans at gmail.com
Fri Mar 28 01:40:10 UTC 2008

David McGlone said the following at 03/27/2008 07:23 PM :

> 6. I executed:
>   ndiswrapper -a 0bda:8197 net8187b.
> what does ndiswrapper -l report?
> if it says driver: <blah blah> hardware present or something very similar, you should be good to go.

yes, it reports that.

> now you need  to do:
> sudo depmod -a
> sudo modprobe ndiswrapper (at this point your light for your wireless should come on If you haven't already got to this point)

I did those. Yes, the light is on.

I can do an "ifconfig -a" and I now see an entry labelled "wlan0", but I
don't know what to do to actually use it.

> 8. So now what? How do I actually access and/or configure the wifi network?
> you should be able to go into the control pannel and configure your wireless card and connection.

Can you give me some details, please? I'm probably being incredibly dense,
but it's simply not at all obvious to me where I should be looking, nor
what I should do when I find it.

(I'm sure you can tell, this is the first time I've tried to use wifi with

> In fact, how do I even find out that everything really has installed correctly?
> to find out use the command ndiswrapper -l (like I mentioned above you should get driver:net8187b hardware present.)
> PS: To get a list of commands for ndiswrapper just type ndiswrapper 

Yes, I understand all the ndiswrapper stuff, and that all looks like it
worked. It's the NEXT step where I don't have a clue what to do. Googling
wasn't any help either; basically everything I found said things like
"configure the interface" without suggesting how one might do that.

I tried firing up kwifimanager, but that seemed to think I was in ad-hoc
mode, which I'm not, and even though scanning found my two wlans, I
couldn't figure out how to actually connect to one of them.

I also tried ifdown and ifup: ifdown complained that wlan0 wasn't
configured, and ifup said "ignoring unknown interface wlan0=wlan0".

I'm really flailing around here :-(

It seems like the next step has to be to connect wlan0 to an actual wlan,
but I can't find the magic command to do that :-(


More information about the kubuntu-users mailing list