nspluginwrapper which viewer ?

Phil Pinkerton pcpinkerton at gmail.com
Tue Sep 11 11:33:04 BST 2007


The last Gutsy upgrade, dist-upgrade resulted in the following message. 
What viewer is it looking for ?

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  gnome-app-install
The following packages will be upgraded:
  bluez-cups bluez-utils cpp-4.2 devscripts espeak espeak-data g++-4.2 
gcc-4.2 gcc-4.2-base gcj-4.2 gcj-4.2-base gdb gfortran-4.2 gij-4.2 grub
  human-icon-theme imagemagick launchpad-integration lib32gcc1 
lib32stdc++6 libecj-java libespeak1 libexiv2-0 libgcc1 libgcj-doc 
libgcj8-1 libgcj8-1-awt
  libgcj8-dev libgcj8-jar libgdome2-cpp-smart0c2a libgfortran2 libgomp1 
libid3-3.8.3c2a libkpathsea4 liblaunchpad-integration0 liblpint-bonobo0 
libmad0
  libmagick9 libmms0 libmusicbrainz4c2a libnm-glib0 libnm-util0 
libopenexr-dev libopenexr2c2a libstdc++6 libstdc++6-4.2-dev libtunepimp5 
libuniconf4.3
  libwpd-stream8c2a libwpd8c2a libwps-0.1-1 libwvstreams4.3-base 
libwvstreams4.3-extras lshw network-manager python-launchpad-bugs
  python-launchpad-integration rss-glx tomboy xfce4-session xvnc4viewer
61 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 104MB of archives.
After unpacking 307kB of additional disk space will be used.
Do you want to continue [Y/n]? y

snip ... update went ok


apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  sexy-python
The following NEW packages will be installed:
  python-sexy
The following packages will be upgraded:
  flashplugin-nonfree gnome-app-install
2 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 497kB of archives.
After unpacking 4096B of additional disk space will be used.
Do you want to continue [Y/n]? y

Setting up flashplugin-nonfree (9.0.48.0.0ubuntu9) ...
Installing from local file 
/var/cache/flashplugin-nonfree/install_flash_player_9_linux.tar.gz
Flash Plugin installed.
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading 
shared libraries: libXcomposite.so.1: cannot open shared object file: No 
such file or directory

nspluginwrapper: no appropriate viewer found for 
/usr/lib/flashplugin-nonfree/libflashplayer.so


Phil





More information about the kubuntu-users mailing list