Distribution upgrade from 7.04 to 7.10 hangs on "configuring libgcc1"

darshak shah darshak.s at gmail.com
Mon Oct 29 06:21:57 UTC 2007

I tried to upgrade from 7.04 version to 7.10 using the adept package
I had kept the machine in the office over the weekend for installation, it
had successfully downloaded all the upgrades,
And when it tried to install them, it was hung on "configuring libgcc1" for
a long time.

After that, I closed the upgrade process manually, and rebooted the machine
Then when I tried to open the adept manager again, it gives me this error.

"Another process is using the packaging system database (probably some other
Adept application or apt-get or aptitude). Please close the other
application before using this one."

I have no other application running which is locking the package manager.
I suspect that when I closed the "Distribution Upgrade" manually, it has not
released/deleted the corresponding lock file.

After this step I was trying to run "sudo apt-get update" on the command
This step ends with this error.
Fetched 6B in 4s (1B/s)
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to
correct the problem.

And when I tried "sudo dpkg --configure -a" I get the following error.

darshak at darshak-machine:~$ sudo dpkg --configure -a
dpkg: parse error, in file `/var/lib/dpkg/updates/0006' near line 2 package
 `triggers-pendi' is not allowed for third (status) word in `status' field

I have no idea how to move ahead from this step.
I want to upgrade my distribution to 7.10, and I have all the necessary
packages downloaded in my "/var/cache/apt/archives/" which is approx 1.4 GB,
which I do not want the apt manager to download again.

Thank you in Advance!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20071029/b06538e5/attachment.html>

More information about the kubuntu-users mailing list