need to unplug USB drive

Sylviane et Perry White spwhite at
Sun Oct 28 10:35:34 UTC 2007

On Sunday 28 October 2007 00:16, D. Michael McIntyre wrote:
> On Saturday 27 October 2007, Sylviane et Perry White wrote:
> > But trying to increase the permission at 777 had no effect for user B and
> > the setting was back at 755 after su(ing) again to user A.
> >
> > 4)	***What do you suggest?***
> In looking, I think I've suggested this before, because this file looks
> familiar.  I don't remember if the person I tried to help last time had any
> success or not.  No clue.
> It looks like the file to edit to change what permissions these things get
> mounted with automatically is /etc/udev/rules.d/40-permissions.rules
> There's a line in there:
> # USB devices (usbfs replacement)
> SUBSYSTEM=="usb_device",                MODE="0664"
> I think I'd change that to read:
> # USB devices (usbfs replacement)
> #SUBSYSTEM=="usb_device",                MODE="0664"
> SUBSYSTEM=="usb_device",                MODE="0000"
You probably mean MODE="0777"
> And see if you magically get things mounted world writeable by everybody.
> I'm just pulling this out my ass though, and have no fricking idea if it's
> the right approach, or will even work.  I haven't actually had more than
> one user on the same computer in a very long time, and have never run into
> your issue first-hand.
> So take these thoughts for what they're worth, which might be zippity
> doodah. --
> D. Michael McIntyre

Thanks, I didn't even know about this file,but that didn't work. 
I tried both with values higher or lower than 0664, with or without reboot, no 
No surprise after all because I always had 755 when the device was inserted.

I made some "progress" though:
I thought I should also set /media to 777.
Setting /media/usbdisk to 777 always resulted in a message to the effect the 
modification was effective and that could be seen with ls or in Konk's 
window, *but* only as long as the device was not inserted (folder icon in 
Konk's). As soon as the device was inserted the icon turned into a "usb drive 
icon" and the permissions were back to 755...any attempt to chmod would 
pretend to success but fail (be overridden?) See the Konsole output_
....perry at kubuntu:/$ chmod -c 777 /media/disk
....Le mode d'accès de `/media/disk' a été modifié à 0777 (rwxrwxrwx).
....perry at kubuntu:/$ ls -ld /media/disk
....drwxr-xr-x 4 perry root 16384 1970-01-01 01:00 /media/disk

I still do not understand what happens when you mount a device, it appears as 
though the mount point is a placeholder that gets replaced by the mounted 
stuff. During my attemps I even accidently mounted the device directly 
unto /media. Took me a long time to figure out how to straighten things up 
and I was relived to see all the other drives that had dissepeared 
from /media (showing only the disk's content) then reappeared.

Thanks		Perry
BOFH excuse #299: The data on your hard drive is out of balance

More information about the kubuntu-users mailing list