need to unplug USB drive

Nigel Ridley nigel at
Thu Nov 1 15:36:31 UTC 2007

Sylviane et Perry White wrote:
> On Sunday 28 October 2007 15:45, Earl Violet wrote:
>> --- Nigel Ridley <nigel at> wrote:
>>> Sylviane et Perry White wrote:
>>>> Hi,
>>>> If I plug in my "SanDisk" as user A, A becomes the owner.
>>>> Then if I change session to user B, B cannot write to the
>>> "SanDisk"
>>>> I tried to su as user A (perry) and use chmod, but to no avail:
>>>> I was able to decrease the permissions to 700 (that made the
>>> drive not
>>>> accessible at all for user B)
>>>> But trying to increase the permission at 777 had no effect for
>>> user B and the
>>>> setting was back at 755 after su(ing) again to user A.
>>>> I also explored the system settings  and got the access right
>>> bars ungreyed
>>>> (clickable) in the access-right tab of the properties for the
>>> disk ( and also
>>>> managed to have executable programs work directly from the drive)
>>>> That was of no help because I could not make those permissions
>>> stick(y)
>>>> Had no luck on Google either.
>>>> Solutions:
>>>> 1) Pull out and plug in again the disk ("safely remove does not
>>> work here")
>>>> 	_simple but not elegant.
>>>> 2) Change session to user A, "safely remove" and change again to
>>> user B.
>>>> 	_tedious, and does not work unless disk is physically removed.
>>>> 3) su as A and use command lines to write.
>>>> 	_my wife can't do that  ;-)
>>>> 4)	***What do you suggest?***
>>>> Thanks for pointers		Perry
>>> There is a similar problem with other auto-mounted media devices.
>>> The same thing happens with a data CD or a digital camera (USB). My
>>> daughters' computer will sometimes have 2 active users (with one of
>>> them
>>> having inserted a data CD) and then I come along (and log into my
>>> account) to do something with the cdrom and can't unmount it
>>> because
>>> there are already 2 users 'accessing' it. I try to eject/unmount it
>>> but
>>> get the 'Device in Use' message (or something similar) - so I
>>> switch
>>> users and try again only to get the same message. I have to log
>>> everybody out except for one user then eject/unmount it.
>>> There must be a better way to manage auto-mounted media devices.
>>> Blessings,
>>> Nigel
>> I have a similar problem with my USB stick.  
> IMHO only to a certain extent.
>> I can copy a file to it 
>> but when it comes to loading it on another computer,
> Do you mean you cannot read from the stick or copy  its files to the 2nd 
> computer?
>> I need to move  it as root and change the permissions.
> The permissions of the stick or of the files within?
>> Earl
> Hi Earl,
> I wouldn't be too surprised if you could solve your problem before Nigel or I.
> As for Nigel's CD I couldn't eject my USB stick and our problem is probably 
> related to the way  "this automagic stuff" mounts the volumes. 
> Perhaps everybody with some version of Linux has these problems (I tried my 
> stick with 2 users under M$, both could write to it). We may call that a bug 
> (unless it is an option).
> Your problem is much more serious, in the sense that it invalidates the whole 
> purpose of the USB stick (file transfer), but it may be simpler to solve 
> (just a guess).
> The great difference between your case and ours is that you unplugged and 
> replugged the stick... the person on the 2nd machine should then become the 
> owner of the stick, so something else must be locking your files.
> I would first check if the problem doesn't come from the permissions of the 
> folders and files inside the device. Try it on M$ perhaps. Don't give up too 
> soon.
> cheers		Perry

This might help:

I stuck dsl-n (Damn Small Linux - not) Live CD in the laptop, mounted 
the USB drive, changed the 'group' ownership to 'users' (keeping the 
'user' as root), added myself to the group 'users' on my Kubuntu box 
(logged out and back in again - for the group change to take effect) and 
now I can write to the USB drive on both the laptop and the Kubuntu box 
(and I suppose, any Linux box as all distros have the group 'users' as 
standard - just need to be added to group 'users').



OliveRoot Ministries

More information about the kubuntu-users mailing list