Apt-get wants to downgrade my Digikam

Dotan Cohen dotancohen at gmail.com
Fri Jan 19 15:37:39 GMT 2007


I installed digikam 0.9.0 from source, as it's not in any ubuntu repo.
I also installed exiv2 0.12 from source in order to install digikam.
Now, when I run apt-get it wants to remove my Digikam:

dotancohen at ubuntu:~$ sudo aptitude install konq-kim
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
  digikam digikamimageplugins
The following packages have been automatically kept back:
  kppp kword-data libkadm55 libkrb5-dev librss1
  linux-restricted-modules-2.6.17-10-generic
  linux-restricted-modules-common vmware-player-kernel-modules-2.6.17-10
  xserver-xorg-core
The following NEW packages will be automatically installed:
  imagemagick libmjpegtools0c2a libquicktime0 mjpegtools
The following packages have been kept back:
  kdenetwork-filesharing kdenetwork-kfile-plugins kdnssd koffice-data
  koffice-libs kpf krdc krfb krita krita-data kspread kword libkrb53
  libpoppler1 libpoppler1-qt poppler-utils tzdata wine
The following NEW packages will be installed:
  imagemagick konq-kim libmjpegtools0c2a libquicktime0 mjpegtools
0 packages upgraded, 5 newly installed, 0 to remove and 27 not upgraded.
Need to get 1759kB of archives. After unpacking 6124kB will be used.
The following packages have unmet dependencies:
  digikam: Depends: kdelibs4c2a (>= 4:3.5.5-1) but 4:3.5.5-0ubuntu3 is
installed.
           Depends: libfontconfig1 (>= 2.4.0) but 2.3.2-7ubuntu2 is installed.
           Depends: libqt3-mt (>= 3:3.3.7) but 3:3.3.6-3ubuntu3 is installed.
           Depends: libsqlite3-0 (>= 3.3.8) but 3.3.5-0.2 is installed.
  digikamimageplugins: Depends: kdelibs4c2a (>= 4:3.5.5-1) but
4:3.5.5-0ubuntu3 is installed.
                       Depends: libfontconfig1 (>= 2.4.0) but
2.3.2-7ubuntu2 is installed.
                       Depends: libqt3-mt (>= 3:3.3.7) but
3:3.3.6-3ubuntu3 is installed.
                       Depends: libsqlite3-0 (>= 3.3.8) but 3.3.5-0.2
is installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Downgrade the following packages:
digikam [1:0.9.0~beta3-3 (now) -> 1:0.8.2-2ubuntu1 (edgy)]
digikamimageplugins [0.9.0~beta3-3 (now) -> 0.8.2-3 (edgy, edgy)]

Score is -130

Accept this solution? [Y/n/q/?] n
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
digikamimageplugins

Downgrade the following packages:
digikam [1:0.9.0~beta3-3 (now) -> 1:0.8.2-2ubuntu1 (edgy)]

Leave the following dependencies unresolved:
digikam recommends digikamimageplugins
Score is -591

Accept this solution? [Y/n/q/?] n
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
digikam
digikamimageplugins
kubuntu-desktop

Score is -1003

Accept this solution? [Y/n/q/?] n
Resolving dependencies...

*** No more solutions available ***


What can I do to tell it to just ignore the digikam dependancies?
Thanks in advance.

Dotan Cohen

http://what-is-what.com/what_is/energy.html
http://dotancohen.com/howto/linksyssetup/index.php



More information about the kubuntu-users mailing list