Opera - unmet dependancies

Thilo Six T.Six at gmx.de
Sun Sep 24 12:22:42 BST 2006


gabrielle harrison and Paul van den Bergen wrote the following on
24.09.2006 13:07:
> Hi all,
> 
> so, this is what I get...
> 
>   # apt-get -f install opera
> Reading package lists... Done
> Building dependency tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> 
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>    opera: Depends: libqt3c102-mt (>= 3:3.2.1) but it is not installable

<snip>


Which Distri Version are using? Dapper, Breezy...?

$ apt-cache policy opera
opera:
  Installiert:(keine)
  Mögliche Pakete:9.00-20060616.7
  Versions-Tabelle:
     9.00-20060616.7 0
        500 http://archive.canonical.com dapper-commercial/main Packages


$ aptitude show opera
Package: opera
New: yes
State: not installed
Version: 9.00-20060616.7
Priority: optional
Section: non-free/web
Maintainer: Opera Packaging Team <packager at opera.com>
Uncompressed Size: 12.7M
Depends: libc6 (>= 2.1.3), xlib6g (>= 3.3.6) | xlibs | libxmu6,
libqt3-mt (>= 3.3.4), libstdc++6


as you can see here, opera does not directly depend on libqt3c102-mt,
but libqt3-mt has somewhat a relation to it:


$ aptitude show libqt3-mt
.
.
.
Conflicts: libqt3c102-mt, libqui1-emb, libqt3c-mt
             ^^^^^^^^^^

Just to see what depends on libqt3c102-mt i would:
$ sudo aptitude purge libqt3c102-mt

!!!!   do not plain accept it, read the ouput crefully, !!!!
!!!!            if uncertain hit "n" to abort           !!!!



and post it´s output here

bye Thilo
-- 
i am on Ubuntu 2.6 KDE
- some friend of mine

gpg key: Ox4A411E09




More information about the kubuntu-users mailing list