unable to write to usb mp3 player - how to change permissions for a device

Tez binary_y2k2 at blueyonder.co.uk
Tue Sep 26 18:28:02 BST 2006


Fun Kid wrote:
> Hello Tez,
>
> The command 'ls -ld /media/rio' gives me the result:
> drwx------ 3 user user 6144 1969-12-31 19:00 /media/rio
>
> I don't quiet understand the permissions for the file but I tried 
> to change the permission by typing the command:
> user at ss-xubuntu:~$ chmod og=rw /media/rio/
>
> But it did not work.  The result I got was:
> chmod: changing permissions of `/media/rio/': Read-only file system
>
> Nevertheless, I tried to open Krusader and copy a music file from 
> my music folder to /media/rio and it did not work.  I got the 
> message I had gotten before:
> 'Could not write to /media/rio/Heaven.mp3'
>
> Not sure what is going on.  Thanks for helping me figure this out.
> Fun Kid
>
>   

"chmod: changing permissions of `/media/rio/': Read-only file system"
This tells me something, it seems that the file system is mounted as
read-only for some reason, no wonder you can't write to it.
Unmount the device with "pumount [device]" and try remounting it with
the "-w" flag to pmount: "pmount -w /dev/sda1 rio" and then check that
it's mounted read/write with "mount|grep rio" you should see something like
"/dev/sda1 on /media/rio type vfat (rw)"
as long as you see "rw" somewhere then you should be able to write to it.

As a last resort you can try mounting it like:
"sudo mount -t vfat /dev/sda1 /media/rio -o uid=user,gid=user" change
uid=user and gid=user to match your username, you should then be able to
write to it.

Tez





More information about the kubuntu-users mailing list