Kubuntu instability...

Branko Vukelic bg.branko at gmail.com
Wed Oct 25 07:36:02 UTC 2006

On Tuesday 24 October 2006. 20:56, Felipe Figueiredo wrote:
> Em Tuesday 24 October 2006 13:59, Branko Vukelic escreveu:
> > On Tuesday 24 October 2006. 14:04, Tchize wrote:
> > > This is not odd, it just mean only one application can manage
> > > installation at a time. You surely don't want to see your installation
> > > corrupted because 2 differents apps tried to update it simultaneously.
> >
> > No, I mean, aptitude locks dpkg, and it stays locked even after I exit
> > aptitude...
> Are you sure the applitacion locking the deb db is aptitude? It could very
> well be one of ADEPT's offspring (adept_updater comes to mind). I had once
> my aptitude blocked, and it was this adept_something that had silently
> crashed in the background. I killed it and everything went fine (didn't
> need to restart KDE).

Hmm, it could be it. But it's still odd. It happens whenever I run aptitude 
and try to install/remove stuff. Aptitude seems to exit cleanly but there's 
the lock after I start any package manager INCLUDING aptitude. Last time it 
happened, I did not even update the database... Usually, the notifier pops up 
when the database is refreshed, but I don't like to use it anyway.

One other problem I'm facing with aptitude is that it constantly tries to 
remove most of the packages (whole of KDE, OpenOffice, python, etc) claiming 
they are no longer needed... I just press + for the entire group and the 
problem if fixed for that session, but next time I launch aptitude, it again 
tries to remove the same packages. Any way to fix that?

> Give memtest a try. Also check if you have bad IDE/SATA cables, proper
> CPU/case ventilation, etc.

Apart from memory test, I would rule out any other hardware trouble. I changed 
IDE cables a few weeks ago and they work as expected. I also tested the drive 
itself because I'm using the same disk I recovered lost photos from. I had to 
check it during recovery. As for CPU/Case ventilation, I installed two extra 
fans into the case, so I doubt it is the CPU overheating.

I will run memory test this weekend, and see if this is causing the trouble. I 
have a RIP Linux with memtest on it.

At this moment, Kubuntu seems to run normally... for now. After a recent 
update of libqt3-mt package, my uptime is more than 16 hours, which is quite 
promissing. Maybe that was causing trouble?

More information about the kubuntu-users mailing list