wpa_supplicant

Howard Coles Jr. dhcolesj at gmail.com
Sun Mar 26 04:34:09 BST 2006


Does anyone know what happened to wpa_supplicant?  yesterday my wireless was 
working, (even though its gotten to where I have to manually modprobe my 
madwifi driver) however now, I can't get wpa_supplicant to load.

I'm running dapper.
wpa_supplicant version is now 0.4.8-0ubuntu1

Here's the message I receive when I enter:  wpa_supplicant -w -iath0 
-c/etc/wpa_supplicant manually:

root at homep4:/etc# wpa_supplicant -w -iath0 -c/etc/wpa_supplicant.conf -d
Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 'default' 
ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
Priority group 0
   id=0 ssid='myssid'
Initializing interface (2) 'ath0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=19 WE(source)=13 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
Own MAC address: 00:00:00:00:00:00
wpa_driver_hostap_set_wpa: enabled=1
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
Driver does not support WPA.
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_countermeasures: enabled=0
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
wpa_driver_hostap_set_drop_unencrypted: enabled=1
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not supported
Setting scan request: 0 sec 100000 usec
Added interface ath0
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=17):
     [hex code]   [myssid]
     37                                                7
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
Scan timeout - try to get results
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
Scan results: -1
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
Wireless event: cmd=0x8b19 len=8
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
Scan results: -1
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b19 len=8
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
Scan results: -1
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=17):
     [hex code]   [myssid]
     37                                                7
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to initiate AP scan.
Setting scan request: 10 sec 0 usec
Wireless event: cmd=0x8b19 len=8
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
Scan results: -1
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b19 len=8
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable
Scan results: -1
Failed to get scan results
Failed to get scan results - try scanning again


It appears that I have no /var/run/wpa_supplicant file any longer, and that 
wpa has been disabled for the driver.  My question is what should be in that 
file?  I found an /etc/default/wpasupplicant file, should I copy that 
to /var/run?

-- 

See Ya'
Howard Coles Jr.
John 3:16!

Christian Books On-Line http://risenbooks.com
http://home.comcast.net/~dhcolesj



More information about the kubuntu-users mailing list