is not a symbolic link

Nigel Ridley nigel at
Sat Jul 29 03:51:54 UTC 2006

Jody Storme wrote:
> On Friday 28 July 2006 12:43, Nigel Ridley wrote:
>> I just did a dist-upgrade after previously 'applying the fix for the KDE
>> screensaver bug' (which involved replacing the file
>> /usr/lib/ with a compiled version made available
>> thru the kubuntu wiki) and got the following error message:
>> ldconfig: /usr/lib/ is not a s
>> So now every time I install, or upgrade something to do with KDE I get
>> the same error message :-(
>> What is the fix for this? Anybody else noticed this error?
>> Nigel
> I've never seen this error before, but the first thing that I would try would 
> be to rename the file and link to it, something like this:
> 	mv /usr/lib/
> 	ln -s /usr/lib/ /usr/lib/
> That way maybe KDE will detect that it is a symlink (even though it's still 
> pointing to the original file) and not complain.
> Hope that helps,
> Jody

Thanks Jody - that solved it.

It is kind of strange though as the original file didn't seem to be a 
symbolic link either.





More information about the kubuntu-users mailing list