udev problems - breezy - SUCCESS!

Art Alexion art.alexion at verizon.net
Thu Jan 19 16:22:16 GMT 2006


Derek Broughton wrote:

>Art Alexion wrote:
>
>  
>
>>Ever since upgrading hoary->breezy, I have not been able to connect my
>>palm device via usb for syncing.  It appears it is a udev problem.  Has
>>anyone else experienced this?  Solutions?
>>
>>the kde system services dialog indicates the udev is not running, but
>>cautions when I try to start it from there.  Could that be the problem?
>>    
>>
>
>udev is always running (/sbin/udevd).  It isn't a kde system service, so you
>wouldn't see it there.
>  
>
>>Pointer to a udev how-to aimed at users (as opposed to programmers)?
>>
>>    
>>
>Yes, http://www.reactivated.net/writing_udev_rules.html
>
>This used to be included as part of the udev package.  Too bad it isn't
>anymore.
>
>I keep forgetting to try out kpilot under ubuntu.  I've been just syncing my
>palm to my XP desktop for months.  You may need to go back to
>trying /dev/pilot instead of /dev/ttyUSB*.
>  
>
Thanks, Derek.  The document was great, and I solved my problem.

Some odd things about breezy that were possibly what was screwing things up:

   1. the rules in the /etc/udev/rules.d/ directory are supposed to
      follow the naming convention 00-*.rules through 50-udev.rules (the
      latter of which defines the defaults.  udev applies these rules in
      order.  In Breezy 50-udev.rules is named just, udev.rules.  Other
      included rules have the initial number preceded by the letter z,
      e.g. z60_alsa-utils.rules.  None of the udev documentation
      mentions these non-conforming  file names. These non-conforming
      filenames are in fact, symlinks to files in the parent /etc/udev
      directory.  Again, no documentation explains this, as all docs say
      the rules are supposed to be in /etc/udev/rules.d.  Does anyone
      know why [k]ubuntu does this?  In any case, I copied
      /etc/udev/rules.d/udev.rules to the default name 50-udev.rules.
   2. There was an included rule called 00-palm.rules.  The info
      contained in it was wrong for my Samsung i500 palm phone, and was
      executing before -- and thereby superseding -- the rule I created
      10-palm.rules (using the info contained in the article you
      referenced).  I renamed that file 00-palm.rules~ as udev only
      reads files ending in the .rules extension.

I don't know which of the above, or both, which were preventing my
syncing, but it works now.

Thanks for the help, and if anyone needs more info for getting it to
work, let me know.  I feel I tried everything before this started
working.  It really shouldn't be this hard for users to configure
something so routine.

-- 

_______________________________________
Art Alexion
Arthur S. Alexion LLC

PGP fingerprint: 52A4 B10C AA73 096F A661  92D2 3B65 8EAC ACC5 BA7A
The attachment -- signature.asc -- is my electronic signature; no need for alarm.
Info @ http://mysite.verizon.net/art.alexion/encryption/signature.asc.what.html

Key for signed PDFs available at
http://mysite.verizon.net/art.alexion/encryption/ArthurSAlexion.p7c
The validation string is TTJY-ZILJ-BJJG.
________________________________________

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 374 bytes
Desc: OpenPGP digital signature
Url : http://lists.ubuntu.com/archives/kubuntu-users/attachments/20060119/89a352c6/signature.pgp


More information about the kubuntu-users mailing list