possible FQA: debian and Kubuntu compatibility; Xemacs

Rich Johnson nixternal at ubuntu.com
Wed Dec 20 15:35:45 GMT 2006


On Wednesday 20 December 2006 08:19, Uwe Brauer wrote:
[SNIP]

|     -  Can  debian package be installed under

Some packages can be installed, and some cannot. Of course the MOTU goal is to 
make sure that all packages are interoperable like that.

|     -  Can I just add say # Testing
| deb http://ftp.de.debian.org/pub/debian testing main contrib non-free
| deb http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib
| to the source list? If so why isn't this the default?

As of right now, if you did this, you could do 1 of 3 things to your system:
 
1. Nothing - version differences might be higher in Ubuntu, therefore making 
the Debian packages look older (not 100% sure on this)

2. End up with Debian and not Kubuntu

3. Broken! 

|     -  I was looking especially for XEmacs which is not part of the
|        standard Kubuntu repository.

XEmacs is in the Universe repository, which if you are using Edgy, should be 
setup by default. If you are familiar with your /etc/apt/sources.list and how 
to change them, here is a copy that I use (note I don't use 3rd party repos, 
these are all of the stock Ubuntu repos)
-------------------------------------------------------------------------------------------------------------

# APPLICATIONS
deb http://us.archive.ubuntu.com/ubuntu/ edgy main restricted universe 
multiverse
deb http://us.archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe 
multiverse
deb http://us.archive.ubuntu.com/ubuntu/ edgy-backports main restricted 
universe multiverse

# SECURITY
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe 
multiverse

# SOURCE CODE
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy main restricted universe 
multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy-updates main restricted 
universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy-backports main restricted 
universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted 
universe multiverse

-------------------------------------------------------------------------------------------------------------
You do not need the # SOURCE CODE section unless you plan on doing some Ubuntu 
packaging. Once you have that, or something similar in 
your /etc/apt/sources.list, then do a 'sudo apt-get update && sudo apt-get 
install xemacs21' without the '' of course.

-- 
Rich Johnson
nixternal at ubuntu.com
GPG Key: 0x2E2C0124
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/kubuntu-users/attachments/20061220/2a1b6dcd/attachment-0001.pgp 


More information about the kubuntu-users mailing list