k3b permissions error

Grumpy_Penguin grumpypenguin at qwest.net
Sun Dec 10 16:07:32 GMT 2006


On Saturday 09 December 2006 08:52, Paul Kaplan wrote:
> On Saturday 09 December 2006 9:17 am, D. Michael McIntyre wrote:
> > On Saturday 09 December 2006 6:59 am, Dotan Cohen wrote:
> > > Paul, as much as I'm going to get flamed for this, I always run k3b as
> > > root. It's the only 100% sure way to avoid those permissions problems
> >
> > I'm not going to flame you.  I have to do this too, and I don't
> > understand why.  K3B scans for permissions at startup, and does not
> > detect any problems. If I run the setup utility manually, it finds
> > nothing to complain about.  Yet whenever I try to burn something, I get a
> > message similar to "I/O Error!  See log for details."  The log is always
> > empty of any clue at all.  It just fails for no apparent reason, and I
> > have no clue what to do about it.
> >
> > It's got to be permissions on something that k3bsetup doesn't check for,
> > but what?  I've tried to strace it to no avail, tried various other
> > ideas. At the end, I just run it as root and sigh.
>
> Yeah.  I've tried setting the suid bit on /usr/bin/cdrecord,
> /usr/bin/cdrdao, and /usr/bin/cdparanoia.  Obviiously something else is
> needed.
> Clearly a bug or oversight in k3bsetup, unless it's a feature...but for
> what purpose?
> Paul
I have had this error message before   make sure that the cdrom is *NOT* 
mounted  as that is usually the cause  [damn automount]



More information about the kubuntu-users mailing list