Zire 31 working with Dapper anyone ?

Anita Lewis ajlewis2 at highstream.net
Tue Aug 15 20:22:09 BST 2006


Roshan Mansinghani wrote:
> Does your script use ttyUSB1 or pilot?  I have found that continually 
> trying to sync will cause the module to produce not just ttyUSB1 and 
> ttyUSB0, but ttyUSB2 and ttyUSB3 as well.  Everytime you hit the hotsync 
> button, you should run dmesg in another terminal to see which /dev nodes 
> were created.  The easiest way around this is to use a udev rule that 
> maps all of them to /dev/pilot.  This is the way I have it set up 
> (though I do not use a Zire 31).  In /etc/udev/rules.d/10- custom.rules 
> I have the following line:
> 
> BUS="usb", SYSFS{product}="Palm Handheld*", KERNEL=="ttyUSB*", 
> SYMLINK="pilot",
> MODE="666"
> 
> See if that can get you some more consistency on the timings between 
> when you press the hotsync button and when you run your sync command.
> 

I use exclusively /dev/pilot.  The script is simple:

#! /bin/bash
pilot-xfer -p /dev/pilot -u /home/ajlewis2/Documents/palm/.jpilot/

I have the line for Palm which came by default with Ubuntu.  I had to 
write my own for Debian. It is like yours.  I took out the one I had put 
in rules in a file which has a line for the jump, camera, mp3player and 
zip drive.

The problem seems to be the hub, but now that I think of it, I had no 
problem getting on the jump/thumb drive using the hub.

I think it is more than just the timing, because the timing didn't 
matter when I was not using the hub this morning.  I consistently synced 
three times in a row by being sure that I unplugged, plugged back in, 
and then hit Hotsync prior to running the pilot-xfer script.

I ran it off the hub many times and only got a sync once.  I tried 
unplugging and replugging several times as well.

Anita




More information about the kubuntu-users mailing list